stalling at idle issue and jolts at around 50mph - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-28-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Buford, GA
Posts: 6
stalling at idle issue and jolts at around 50mph

I have an 2002 ford ranger, recently it has started to give me some trouble.

My truck will sometimes jolt at higher speed and when you are taking off from a stop. When taking off from a stop it will also jolt kind of like the truck isnt getting gas and it will jolt a couple times and then go. It will also jolt once or twice at higher speeds around 50mph, which feels like a rougher jolt that will most of the time jolt just once but sometimes twice. What could that be?

one more thing. I was on my way home one night and the truck was idling REALLY bad and was jolting like it wasnt getting gas bad. then my check engine light came on and said it was my camhaft sensor malfunctioning. So I replaced it and the idle problem seems to be gone.

Im not sure if this helps with anything but about a month ago my truck developed a squek at idle. I just figured it was a belt. Then it would idle rough sometimes and stall out. If the AC was on it seemed to make the idle worse and stall out more. My buddies mechanic friend thinks it is just some bad spark plug wires messing it up. AFTER i replaced the camshaft sensor it has not stalled out at idle but it is still jolting at certain times.

ANY help is good. Im a college student living broke so I would rather keep it out of the shop.
Reply With Quote
  #2  
Old 07-28-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
I am also having idling issues on my 05 after replacing the engine this weekend. Idles rough but not stalling... Lack of power below 2000 rpm. Ideas?
Reply With Quote
  #3  
Old 07-28-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
And welcome to r-f Eric! And sorry for the thread hack lol
Reply With Quote
  #4  
Old 07-28-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Buford, GA
Posts: 6
haha thanks... and no problem!
Reply With Quote
  #5  
Old 07-28-2010
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
kyle check yur catalytic converter
Reply With Quote
  #6  
Old 07-28-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
Lol it has nothing to do with my cats
Reply With Quote
  #7  
Old 07-28-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
Quote:
Originally Posted by ranger4.0 View Post
I am also having idling issues on my 05 after replacing the engine this weekend. Idles rough but not stalling... Lack of power below 2000 rpm. Ideas?
forget a ground strap?
Reply With Quote
  #8  
Old 07-28-2010
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
kyle how many klicks on the replacement engine

might be a pending ignition coil failure
Reply With Quote
  #9  
Old 07-28-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
I took the coil and everything off the original engine. I checked all ground straps and vaccuu
lines. It's throwing codes for the throttle position. I am going to swap the sensors and see if that helps
Reply With Quote
  #10  
Old 03-19-2016
Member
 
Join Date: Nov 2014
Location: Anderson, South Carolina
Posts: 31
Wondering if either of you ever found a solution to your problem as I am experiencing some similar issues. Thanks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Advice Needed: Fuel/Stalling Issue cocofosho General Ford Ranger Discussion 1 10-31-2013 09:02 AM
1999 stalling issue nikko SOHC - 2.3L & 2.5L Lima Engines 7 02-11-2013 11:36 AM
Extremely rough idle, and stalling... FMD General Ford Ranger Discussion 8 07-10-2012 03:35 PM
speedometer off at 50mph and below ccernst Drivetrain Tech 9 09-14-2009 11:57 AM
Stalling at idle? b3kbruiser 2.9L & 3.0L V6 Tech 4 12-24-2006 05:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:55 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.