Think we messed up with spark plugs... - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-01-2008
GreenRanger92's Avatar
Member
Thread Starter
 
Join Date: Nov 2007
Location: MO
Posts: 19
Think we messed up with spark plugs...

So a friend convinces me today to get some new spark plugs since mine haven't been replaced since I have had the truck. So we get to replacing, and we can't get to two of the spark plugs. So, we go ahead and switch out four of them, and leave the original two in until we can take it to a shop. Everything runs fine and whatnot...for a few hours. About an hour ago I got back into the town my college is in, and when I came to a stop, my truck started vibrating really bad and the rpm's dropped. I pulled away from the light, and you could hear the vibrations in the exhaust. So I pull over and pop the hood to find the engine rocking back and forth. I didn't notice anything in the dark, so I made it home and shut it off, and here I am waiting for it to cool. What should I check? Could it be the two plugs that weren't changed, or a loose wire, or what? I need the truck to get around campus, since its a big campus, and I gotta leave around 9 in the morning...so the sooner I can get help the better. Thanks.
Reply With Quote
  #2  
Old 09-01-2008
Goodysgotacuda's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2008
Location: Las Vegas, NV
Posts: 1,496
I'd look for loose plug wires
Reply With Quote
  #3  
Old 09-01-2008
GreenRanger92's Avatar
Member
Thread Starter
 
Join Date: Nov 2007
Location: MO
Posts: 19
Will do. Any ideas if that isn't the problem? I bet it is but I wanna cover everything in one go
Reply With Quote
  #4  
Old 09-01-2008
john93rangerstx's Avatar
Member
 
Join Date: Mar 2008
Location: WARWICK RI
Posts: 895
vacum lines will do that
Reply With Quote
  #5  
Old 09-01-2008
GreenRanger92's Avatar
Member
Thread Starter
 
Join Date: Nov 2007
Location: MO
Posts: 19
Vacuum lines were good it was a loose spark plug cable, and the spark plug itself could be tightened a little more. Thanks a lot everyone for the ideas everythings runnin good now.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Spark Plugs Wires & Spark Plugs vancouverisland 4.0L OHV & SOHC V6 Tech 8 07-26-2017 12:28 AM
i think i messed up my Xcal2 My05edge General Ford Ranger Discussion 4 05-11-2008 07:54 PM
New Spark Plugs - Better MPG - Halo Plugs SnowWhite 4.0L OHV & SOHC V6 Tech 3 05-29-2007 06:06 AM
PDQ!! Seafoam question......new plugs before, or new plugs after??? Fx4wannabe01 General Technical & Electrical 9 05-22-2007 11:55 AM
UH OH i think i messed up my bezel! HELP! helliboarder Audio & Video Tech 0 10-04-2004 08:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.