2003 4.0 Runs rough in gear - cannot figure this out! - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-27-2012
Member
Thread Starter
 
Join Date: Mar 2008
Location: Wisconsin
Posts: 94
2003 4.0 Runs rough in gear - cannot figure this out!

Truck will idle / run fine in park or idle. But when it is in gear the engine will run rough when i am not on the gas. coming to a stop it will begin to run rough and louder and when i hit the gas she smooths out and runs great.I cannot find any vaccum leaks and So far i have changed:
-Plugs and wires
-Maf
-IAC
-Coil pack
-Pcv Valve

I am completely lost and dont feel like blindly throwng more money at this thing. Any ideas?
Reply With Quote
  #2  
Old 11-27-2012
Member
Thread Starter
 
Join Date: Mar 2008
Location: Wisconsin
Posts: 94
Oh, and also changed the throttle body position sensor... :(
Reply With Quote
  #3  
Old 11-28-2012
Member
Thread Starter
 
Join Date: Mar 2008
Location: Wisconsin
Posts: 94
just signed up to another ranger forum hopefully someone there knows..........
Reply With Quote
  #4  
Old 11-28-2012
Member
 
Join Date: Aug 2010
Location: Welland, ON
Posts: 186
Quote:
Originally Posted by dczys View Post
just signed up to another ranger forum hopefully someone there knows..........
is your idle dropping down too low in gear? It should probably be around 750-850 in gear... if it is dropping down to 500 or less the motor will have a hard time staying running especially with headlights on, or a/c. the alternator when under load really can draw alot of power.

IF you do find out what the issue is please post your results up here too...
Reply With Quote
  #5  
Old 11-29-2012
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
sounds like a vacuum leak to me.
Reply With Quote
  #6  
Old 02-04-2014
loc's Avatar
loc loc is offline
Member
 
Join Date: Feb 2014
Location: roopville,ga
Posts: 28
Hi ,sounds like the pcv valve is sticking ? Shake it & see if it rattles ? If you get a rattle check the iac for built up carbon for starters . my thoughts Roc
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE ChargerOnDavins 2.9L & 3.0L V6 Tech 3 03-23-2015 04:25 PM
2003 Ranger fx4 runs rough Camzranger 4.0L OHV & SOHC V6 Tech 4 12-03-2013 11:27 AM
2003 4.0 sohc Ranger runs rough jhbuild1 4.0L OHV & SOHC V6 Tech 22 08-25-2012 10:18 AM
runs rough when started soemtimes 93rangerxlt4.02007 4.0L OHV & SOHC V6 Tech 28 10-18-2005 09:14 PM
2.9L Runs rough, but only intermittently pooroldranger General Technical & Electrical 4 05-23-2005 10:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.