2004 sohc randomly stalls - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-28-2008
Member
Thread Starter
 
Join Date: Sep 2005
Location: Anaheim,Ca
Posts: 57
2004 sohc randomly stalls

Hello All,
First off, I have been a member of this forum for quite a while. Although I have never posted much, I find all members info on here to be quite knowledgeable. I have learned a lot here on rf.

My question to you all is this. On my way to work Monday, I had my truck suddenly give out while I was on the fwy. I was driving with the flow of traffic at a steady 65 mph. Suddenly, I noticed I was merely coasting and have lost all throttle response. I merged to the shoulder of the fwy and coasted until my truck stalled. The truck would not start at first, but 15 minutes later (after about a 5-10 minute rest from trying to start it) it fired up just as normal. I drove to work without any problems, and continued problem free for a couple days. Thursday on the way home from work, it happened to me twice. once at a stop, the other while accelerating. Today, I encountered the same occurance 4 times while driving home from work. Each time the truck would start after a few minutes of rest.

I have 50k miles on my truck and have never encountered any problems till now. After the first occurance on monday, I replaced the fuel filter. After the occurances on thursday, I had replaced the coil pack thinking it could have something to due with the spark. I'm all out of ideas and now turn to you in search of help. Regular maintenance is performed religiously.

Thank You in advance.
Reply With Quote
  #2  
Old 03-28-2008
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
check the idel air control valve that might have something to do with it also do you have any check engine lights on?
Reply With Quote
  #3  
Old 03-28-2008
Member
Thread Starter
 
Join Date: Sep 2005
Location: Anaheim,Ca
Posts: 57
No check engine light at all, except for when it stalls. Once it starts back up, it disappears. Code reader read nothing at all.

Also, to note, the idle speed operates normally until ready to stall. It will then studder real quick and then die. While under acceleration, there is no studder at all. The accelerator simply quits working.

Last edited by rynzingg; 03-28-2008 at 07:32 PM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 E350 stalls while idling... this truck NEVER stalls. Ever..??? FMD General Ford Discussion 1 10-31-2016 02:53 AM
Signal lights randomly don't work... Ciaran General Technical & Electrical 9 09-23-2008 01:08 PM
Randomly better gas mileage Werty 2.9L & 3.0L V6 Tech 26 11-20-2006 05:37 PM
Air flow goes to defrost randomly GubNi General Technical & Electrical 29 08-12-2006 10:57 AM
4x4 randomly working, electical problem? QWIKSNK Drivetrain Tech 11 06-13-2006 02:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.