7mpg!!!!!!!!!! HELP!!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-23-2009
HillPrideRanger's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Aurora, Colorado
Posts: 442
Icon8 7mpg!!!!!!!!!! HELP!!!!!

ok i gotta BIG problem i started to get 7mpg last monday
before i started getting this shotty milage i replaced my pcv valve, fuel filter, oil and filter and sea fomed the thing

yet im getting only 80miles for a half of a tank.......

i hooked it up to the modis and it was throwing P0174 and P0171 which is bank1 and 2 systems are running too lean. i also am seeing that the data stream is showing no activity coming from my bank 2 O2sencer

which is odd b/c i replaced that same sencer not but 5000 miles ago....

any one have any idea whats up?

Thanks
-Andy

Last edited by HillPrideRanger; 11-23-2009 at 06:26 PM.
Reply With Quote
  #2  
Old 11-23-2009
HillPrideRanger's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Aurora, Colorado
Posts: 442
liar
Reply With Quote
  #3  
Old 11-23-2009
God,Country,FORD's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
what? Why did you just call yourself a liar?
Reply With Quote
  #4  
Old 11-23-2009
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
lmao wtf
Reply With Quote
  #5  
Old 11-23-2009
God,Country,FORD's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2007
Location: Red Oak, IA
Posts: 2,468
haha thats exactly what i was thinking
Reply With Quote
  #6  
Old 11-23-2009
edgerider2002's Avatar
Member
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
oh man haha
Reply With Quote
  #7  
Old 11-23-2009
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
POWED
Reply With Quote
  #8  
Old 11-23-2009
TexasRanger's Avatar
Member
 
Join Date: Jun 2008
Location: austin, TX
Posts: 1,252
maybe your other personality has been using your gas without telling you
Reply With Quote
  #9  
Old 11-23-2009
HillPrideRanger's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Aurora, Colorado
Posts: 442
fin kids gettin on the computer and posting **** and its pissin me off
Reply With Quote
  #10  
Old 11-23-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Liar!! Log off when you go away or lock your pc when you go away.
Reply With Quote
  #11  
Old 11-23-2009
Ranger_Guy15's Avatar
Member
 
Join Date: Apr 2007
Location: MN
Posts: 2,827
haha.
Reply With Quote
  #12  
Old 11-23-2009
john93rangerstx's Avatar
Member
 
Join Date: Mar 2008
Location: WARWICK RI
Posts: 895
LOL THAT SUCKS
Reply With Quote
  #13  
Old 11-23-2009
pacodiablo's Avatar
Member
 
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
The sensor should have at least a one year warranty on it. I'd see about taking it back. Sometimes you just get a bad part.

The things you mentioned doing should not have caused the fuel economy to drop at all.
Reply With Quote
  #14  
Old 11-23-2009
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
lol. How's your tranny? My truck didn't throw those codes, but I was getting the same ****ty mileage. Since you have access to a MODIS, I assume you have access to tests and procedures for your truck. Try doing the Stall Speed Test. Something in your transmission could be ****ed.
Reply With Quote
  #15  
Old 11-23-2009
David N's Avatar
Member
 
Join Date: Dec 2008
Location: Williamston, NC
Posts: 1,060
Wow. lol The PO 171 code is for the little elbow that gets cracked causing a vaccuum leak, which can result in bad gas mileage. But as for 8 mpg... mine doesnt do much better. lol
Reply With Quote
  #16  
Old 11-23-2009
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Did you clean / change the plugs after the seafoam ?
Reply With Quote
  #17  
Old 11-23-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
how are you computing the 7mpg?
Reply With Quote
  #18  
Old 11-23-2009
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
7MPG.......Hell, that's worse mileage then a 70 Chevelle with a 454. They got 8....LOL


BTW, this is too funny:
Quote:
Originally Posted by HillPrideRanger View Post
ok i gotta BIG problem
yay!
i love ****!


Thanks
-Andy
Reply With Quote
  #19  
Old 11-23-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
oh yeah...forgot to comment....

this thread is all over the place. what a riot. lol.
Reply With Quote
  #20  
Old 11-23-2009
fourliter dan's Avatar
Member
 
Join Date: Dec 2007
Location: Lebanon, OR
Posts: 2,229
both those codes came up on mine and i cleaned my mass, no code and better mileage
Reply With Quote
  #21  
Old 11-23-2009
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
if that 02 senser is bosh brand then yes its prob a dud i went through 4 of em before i got a good one
Reply With Quote
  #22  
Old 11-23-2009
TheStig88's Avatar
Member
iTrader: (4)
 
Join Date: Aug 2008
Location: Columbia, Missouri
Posts: 2,120
check your muffler bearings.....make sure they're all lubed up so the air flows more freely
Reply With Quote
  #23  
Old 11-23-2009
HillPrideRanger's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Aurora, Colorado
Posts: 442
bump
Reply With Quote
  #24  
Old 11-23-2009
Ranger093's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: Blaine, Minnesota
Posts: 289
Alright. You said you SeaFoamed it.... Did you change your plugs? If you have recently they probably got all fouled up from carbon composites. Try running some injector cleaner in your gas. Another possibility is that your crank case vent may be plugged. Thats the first tube on your intake. Its got some green tabs on it. One more possibility is that your MAF sensor is all gunked up. Try brake cleaner or some MAF cleaner from an autoparts store. If all that fails, its probably that second O2 Sensor.
Reply With Quote
  #25  
Old 11-23-2009
HillPrideRanger's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Aurora, Colorado
Posts: 442
Quote:
Originally Posted by Ranger093 View Post
Alright. You said you SeaFoamed it.... Did you change your plugs? If you have recently they probably got all fouled up from carbon composites. Try running some injector cleaner in your gas. Another possibility is that your crank case vent may be plugged. Thats the first tube on your intake. Its got some green tabs on it. One more possibility is that your MAF sensor is all gunked up. Try brake cleaner or some MAF cleaner from an autoparts store. If all that fails, its probably that second O2 Sensor.
thanks ill do that and yeah i havent replaced my plugs
and the o2 has a data stream of 0... so i think its that as well
but ill just do all that and try to get my peak back

-Andy
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP !HELP! HELP! 3.0 V6 Driving me insane Hunter74 2.9L & 3.0L V6 Tech 21 03-06-2016 12:08 PM
21.7mpg to 15.4mpg after engine swap Bubblewrap General Ford Ranger Discussion 36 06-25-2011 03:01 PM
Help Help Help!!!!!!! EdgeGOBoom 2.9L & 3.0L V6 Tech 6 09-16-2007 01:01 AM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-16-2005 12:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:29 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.