another high idle issue - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-04-2015
Member
Thread Starter
 
Join Date: Feb 2015
Location: monkey valley, pa
Posts: 13
another high idle issue

hi all, i have read all the high idle posts and they have helped a little. but my problem was an iac valve. i changed that and the temp sensor. now when i start the truck, hot or cold, it revs to 2000 rpm for about 10 seconds and then idles down to 750 ish. but when i put it in gear it revs up to 1100 and likes to idle at about 40 mph. it really has me braking way too much for stop lights and signs. i show no codes and can find no vacuum leaks. any ideas?
Reply With Quote
  #2  
Old 09-05-2015
Member
Thread Starter
 
Join Date: Feb 2015
Location: monkey valley, pa
Posts: 13
oh yeah its an 04 4.0 auto 4x4
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
another high idle question [email protected] 2.9L & 3.0L V6 Tech 19 08-02-2015 01:42 PM
High Idle / Low idle 2003 Ranger 3.0 thom2003 2.9L & 3.0L V6 Tech 1 03-27-2012 01:12 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM
Another Idle Issue for all you FORD Technicians lorenambrose 2.9L & 3.0L V6 Tech 12 05-25-2010 09:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.