bogging bad - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-11-2008
coondog491's Avatar
Member
Thread Starter
 
Join Date: Oct 2007
Location: McAllen, TX
Posts: 10
bogging bad

i have a 4.0 ohv explorer a/t
while driving i cannot go past half throttle without the motor bogging so bad that it actually slows me down.
i have replaced the maf and the crank sensor.
help please!!!
Reply With Quote
  #2  
Old 06-14-2008
Member
 
Join Date: Jun 2008
Location: orlando, fl
Posts: 19
plugs, wires or tps?
Reply With Quote
  #3  
Old 06-20-2008
coondog491's Avatar
Member
Thread Starter
 
Join Date: Oct 2007
Location: McAllen, TX
Posts: 10
found the problem.....
someone poured s**t in my tank!!!!!!!!!!!
damn im pissed
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 07:59 AM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 12:50 PM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 08:21 AM
Bogging CroCop SOHC - 2.3L & 2.5L Lima Engines 8 02-20-2006 12:39 PM
Bogging down feeling PhilpotHunter 2.9L & 3.0L V6 Tech 5 10-07-2005 11:32 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.