CEL came on - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-16-2007
bryanjints's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2005
Location: Mount Holly, NJ
Posts: 1,857
CEL came on

P0442

Not sure why this happened but I was not happy when it came on. Any help would be appreciated.
Reply With Quote
  #2  
Old 09-16-2007
bryanjints's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2005
Location: Mount Holly, NJ
Posts: 1,857
bump


I was reading some stuff on that code and wondered if it had anything to do with me changing out a fuel line last month. The line that goes from the fuel tank to the filter on the driver side frame rail.
Reply With Quote
  #3  
Old 09-16-2007
doc's Avatar
doc doc is offline
Member
 
Join Date: Jun 2004
Location: Media, PA
Posts: 1,406
http://www.f150online.com/forums/sho...ighlight=p0442

Say it is the gas cap? Make sure you reconnected all the hoses in your gas fill neck after you took off the bed.. And make sure it is air tight.
Reply With Quote
  #4  
Old 09-17-2007
bryanjints's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2005
Location: Mount Holly, NJ
Posts: 1,857
well I gave the gas cap a thought. I took it off then put it back on I also filled it up today.

I reset the code we will have to see if it comes back. I don't think I can really get a look at those lines without taking the bed off.
Reply With Quote
  #5  
Old 09-17-2007
Rockledge's Avatar
Member
 
Join Date: Nov 2006
Location: Connecticut
Posts: 479
Quote:
Originally Posted by bryanjints
I was reading some stuff on that code and wondered if it had anything to do with me changing out a fuel line last month.
IMO it probably does. (Not what you want to hear, I know).

IIRC you had to drop the tank or pull the bed to repair the damaged fuel ine. The other line (fuel vapor) might have been kinked or breached during the repair, or maybe it got pulled off by accident during re-assembly.

In any event, that's where I'd start my troubleshooting if I was you.
Reply With Quote
  #6  
Old 09-17-2007
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
i have hte same CEL on. Both my "engine CEL" and "fuel cap CEL" are on, and the fuel cap trips the engine one. So I need to check it out, I somehow blame the body lift!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'93 CEL came on tdaward General Ford Ranger Discussion 7 07-21-2009 04:20 PM
CEL came on last night -kyle- General Technical & Electrical 7 02-22-2008 08:41 AM
CEL came on Sants 2.9L & 3.0L V6 Tech 0 02-16-2008 07:47 PM
code p0174 (CEL) PickupMan92 4.0L OHV & SOHC V6 Tech 7 03-30-2005 02:20 PM
CEL and warranty problems 3LiterBeater General Technical & Electrical 23 10-14-2004 10:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:20 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.