Chronic chugging! - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-26-2007
Member
Thread Starter
 
Join Date: Nov 2006
Location: Corona, CA
Posts: 4
Icon9 Chronic chugging!

98 4.0L that constantly runs horrible anf gets horrible gas mileage... the check engine light is on and when I check the code it says "system to lean" "bank 1" "bank 2" "cylinder four not firing"....I have replaced the oxygen sensors, all 3, replaced the MAS and spark plugs/wires... but the problem persist...what is going on?
Reply With Quote
  #2  
Old 03-26-2007
Member
 
Join Date: Aug 2005
Location: Haverhill, MA
Posts: 1,907
did u gap the plugs right? and running a can of sea foam why not.

i'm sure someone will know of some other things to try
Reply With Quote
  #3  
Old 03-26-2007
Member
 
Join Date: Feb 2005
Location: Canton, GA
Posts: 33
I have my own theory on this... and did a google search on this, as I have been having a similar problem and had those codes a while back...

I have also heard of a fuel pump that has/is going bad causing this problem.... might be worth checking into... I'm gonna try it later next week after I get moved into my new house... If you get to it before I do, lemme know how it goes.
Reply With Quote
  #4  
Old 03-26-2007
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
fuel filter? fuel injectors?

run some fuel cleaner through it.

check spark plug gap and check to make sure the spark plug wires are connected well
Reply With Quote
  #5  
Old 03-26-2007
BBBB51's Avatar
Member
 
Join Date: Oct 2006
Location: Alb. N.M.
Posts: 213
I was getting this code when I had a bad maf,system to lean" "bank 1" "bank 2. Went to the junkyard got 1 and it went away . Was the 1 u got new.
Reply With Quote
  #6  
Old 03-27-2007
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
Unplug the MAF and trying driving it. The PCM will go to a default setting.. but if that's the problem it ought to run better.

Rich
Reply With Quote
  #7  
Old 03-28-2007
Member
Thread Starter
 
Join Date: Nov 2006
Location: Corona, CA
Posts: 4
thank you all. the MAS was new; however I am going to start with the fuel pump and then get a fuel injector cleaning done. I am curious about the sea foam and will look into it. again thanks...Rangers Rule!
Reply With Quote
  #8  
Old 03-28-2007
Roach2004's Avatar
RF Veteran
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
I am sorry for whoring the thread but every time I read the title I think of alcohol! That is all
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Chronic Power Loss uncle buck SOHC - 2.3L & 2.5L Lima Engines 15 06-02-2015 11:54 PM
Jumping\Chugging 99 2.5l kevin b SOHC - 2.3L & 2.5L Lima Engines 3 06-27-2013 12:08 PM
1990 Ranger Truck keeps chugging. ibshopin 2.9L & 3.0L V6 Tech 3 08-08-2011 08:54 PM
chugging when first starting up shuckyd General Ford Ranger Discussion 18 04-14-2008 08:16 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.