Jumping\Chugging 99 2.5l - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-26-2013
Member
Thread Starter
 
Join Date: Aug 2011
Location: monroe la
Posts: 6
Jumping\Chugging 99 2.5l

I have a (99 2.5'l ranger ext cab\step side 2 wheel drive

The bad

The motor is jumping at IDl\low end acceleration it seems
to run better at 3000 rpm it clears up to a point but it still ther
but not as bad under hard acceleration it is there.

And yes the check engine light is on and blink under mild to hard accleleration

OK what have I done so far.

Well let see

I have replaced both coil's pack's twice,

plug wire's twice, plug's once, fule injectors once,

New fule filter, took the catalytic converters off thinking well it my be it

short story it's back on :(

There only two code's are up (streem O2) and (EGR) there wore more
but there gone now like misfire cyl 2, down streem O2, exedra exedra.

Now the motor has less then 20k on it so dose the fule pump,
timeing belt, the truck never ran hot and has had it
oil change every 3000 mile's.

Now what could this be.
It getting to me bad the truck never had
the get up and go like it supposed to but this is just sad.
Reply With Quote
  #2  
Old 06-26-2013
Member
 
Join Date: Jun 2013
Location: Duncan
Posts: 14
what sensors have your replaced? My o2 sensors have given me grief on all vehcles. Have you replaced those?
Reply With Quote
  #3  
Old 06-27-2013
Member
Thread Starter
 
Join Date: Aug 2011
Location: monroe la
Posts: 6
The up streem O2 is bad on the truck but it been bad for over a year

The thruck has just now start'ed to act up with in just the last 2 months

it not that it something else
Reply With Quote
  #4  
Old 06-27-2013
Member
 
Join Date: Jun 2013
Location: Duncan
Posts: 14
So you're getting the o2 error code, you've already done all your ignition and you don't think that maybe the o2 sensor isn't it?
your call.

If you're o2 sensor is bad, you will be getting wrong fuel mixtures, possibly resulting in misfires. That's what the o2 sensor does, it regulates your fuel mixture.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Chugging and Bucking FordNavy 2.9L & 3.0L V6 Tech 3 12-13-2013 12:40 PM
Still chugging ozziedave General Ford Ranger Discussion 3 07-25-2013 08:16 PM
1990 Ranger Truck keeps chugging. ibshopin 2.9L & 3.0L V6 Tech 3 08-08-2011 08:54 PM
chugging when first starting up shuckyd General Ford Ranger Discussion 18 04-14-2008 08:16 AM
Chronic chugging! pure_native 4.0L OHV & SOHC V6 Tech 7 03-28-2007 10:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.