Coolant Leak - Ranger-Forums - The Ultimate Ford Ranger Resource

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Coolant Leak

Reply

 
 
 
  #1  
Old 03-19-2010
jimehat112's Avatar
Member
Thread Starter
Join Date: Aug 2006
Location: Amarillo, Texas
Posts: 41
Icon8 Coolant Leak

Can anyone guess where this coolant is leaking from? I thought is was the hose from the thermostat to the water pump, replaced that last weekend but its back. I tore into it tonight thinking it was one of the freeze plugs but they all seem well seated. its not allot of coolant, I think its only happening at higher rpms when the pressure is highest, as there is almost never any drops on the ground.

 
Reply With Quote
  #2  
Old 03-24-2010
Join Date: Aug 2009
Location: Salmon Arm BC
Posts: 959
is the truck overheating?? is the coolant staying in the radiator? i have 4.0L OHV and i replaced the water pump and gasket last week then got the truck on the road this past weekend and now im having overheating issues, but there's almost no leaking but coolant wont stay in the rad.

told my dad tonight and he thinks mine is a blown head gasket.. maybe thats your problem too.. not sure.. did you check all the hoses and stuff??
 
Reply With Quote
  #3  
Old 03-24-2010
Join Date: Aug 2009
Location: Salmon Arm BC
Posts: 959
heater core froze over winter now i have overheating issues

oops meant to start my own thread. haha sorry..
 
Reply With Quote
  #4  
Old 04-03-2010
Member
Join Date: Mar 2010
Location: Mount Vernon
Posts: 7
Get a pressure test on the cooling system. That will tell a lot. It could be a head gasket - ask me I just replaced the head gasket and the heads (cracked) - not good.
 
Reply With Quote
  #5  
Old 04-03-2010
Member
Join Date: Oct 2009
Location: Aiea, HI
Posts: 59
SOHC engine, check the thermostat housing. The thing is made out of plastic and the upper/lower tend to warp when they overheat. The rubber gasket at the base could have also failed. If it is the thermostate housing, replace the thermostat as well. My O2 cents. For the guy w/ the OHV engine, could be a cracked head or could be lower intake gasket that's blown.
 

Last edited by JDO808; 04-04-2010 at 11:06 AM.
Reply With Quote
  #6  
Old 04-03-2010
Join Date: Aug 2009
Location: Holly Springs NC
Posts: 64
my guess would be either upper or lower thermostat housing (or both as in my case a few months ago), the little seal on the bottom on the lower housing is usually the culprit, when replacing the lower housing replace the two temp sensors because the the new housing was updated and the factory sensors do not seal
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
iplayloudly
2.9L & 3.0L V6 Tech
2
12-12-2011 04:04 PM
silverstang00
2.9L & 3.0L V6 Tech
0
03-06-2009 04:20 PM
Srkasner
4.0L OHV & SOHC V6 Tech
9
03-22-2008 10:45 AM
PW01
4.0L OHV & SOHC V6 Tech
8
12-30-2007 10:06 PM
mindfreak
General Ford Ranger Discussion
9
03-17-2007 08:28 AM


Thread Tools
Search this Thread