got a new tcase motor and still not 4l??? wth?? - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-23-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
got a new tcase motor and still not 4l??? wth??

so i went and got a new t case motor and still it wont shift into 4l. be for i got the new motor i took the old motor off and manually put the t case into 4l and drove it around and it work flawlessly i tested my module and it flashed 4 times is that good or bad or what and i also got a new dash switch. how can i test my dash switch and the module and are there any other parts im missing to check. help me plz because other wise if its not the motor im taking it back and getting me 65 bucks back help help help plz


thanks alot


Cam

Last edited by Downey; 03-24-2008 at 09:17 PM.
Reply With Quote
  #2  
Old 03-23-2008
cboveda's Avatar
Member
iTrader: (1)
 
Join Date: May 2007
Location: Key West, FL
Posts: 97
maybe you just got a back motor.
Reply With Quote
  #3  
Old 03-23-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
do you mean a bad motor?
Reply With Quote
  #4  
Old 03-23-2008
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Its possible the wiring harness is damaged.
Reply With Quote
  #5  
Old 03-24-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
is there anyway to test the switch to select 4h and 4l
Reply With Quote
  #6  
Old 03-24-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
bump
Reply With Quote
  #7  
Old 03-24-2008
kevinsranger's Avatar
Member
 
Join Date: Feb 2008
Location: jersey
Posts: 388
4 blinks is good, have you checked your hubs? clean them and all? i took my dash switch apart and cleaned the contacts and that fixed mine
Reply With Quote
  #8  
Old 03-24-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
i have warn manualy humbs what did you clean it with? i know its not my hub it goes into 4h fine it just wont go into 4l and i have 3.27 gears and i would use it alot for off roading if i had it.
Reply With Quote
  #9  
Old 03-24-2008
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
I missed the whole 94 year thing.

In the commonly failing parts category next the the shift motor is the 4wd computer.

I don't have a ford manual for your year so i cant look up testing the switch.
Reply With Quote
  #10  
Old 03-24-2008
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
The most likely culprit is a bad neutral switch connection. You cannot switch to 4 lo without that.

That's probably all it could be if you can switch it to 4 hi. You should not have replaced the motor if the 4lo was the only problem. Hold on the old motor -- you've got a spare.
Reply With Quote
  #11  
Old 03-24-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
how can i check/fix it?
Reply With Quote
  #12  
Old 03-24-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
?????
Reply With Quote
  #13  
Old 03-24-2008
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Can you start the truck in neutral?

If not try wiggling the lever a bit and see if it starts. It maybe an alignment issue.
Reply With Quote
  #14  
Old 03-24-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
Quote:
Originally Posted by Blhde View Post
Can you start the truck in neutral?

If not try wiggling the lever a bit and see if it starts. It maybe an alignment issue.
dude what are you talking about my truck runs fine and it has a electric t case it runs and drives ok and i have 4h i don't have 4l and i want it. i bought a new switch and it didn't fix it i bought a new t case motor didn't fix it and i checked my module and its fine.
Reply With Quote
  #15  
Old 03-25-2008
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Quote:
Originally Posted by Downey View Post
dude what are you talking about my truck runs fine and it has a electric t case it runs and drives ok and i have 4h i don't have 4l and i want it. i bought a new switch and it didn't fix it i bought a new t case motor didn't fix it and i checked my module and its fine.
If you cant start the truck in neutral then you cant get in 4lo. The same switch is used for both functions.
Reply With Quote
  #16  
Old 03-25-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
my truck is a 5spd i use the clutch
Reply With Quote
  #17  
Old 03-25-2008
kevinsranger's Avatar
Member
 
Join Date: Feb 2008
Location: jersey
Posts: 388
i just took the switch apart and blew it out and wiped it off and stuck it in and it worked, but mine didnt work at all, 4h or 4l didnt work, i didnt read your origional post good, its worth a shot tho
Reply With Quote
  #18  
Old 03-25-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
yeah i tried that and it didnt work im guna have to take it to a dealership ugh
Reply With Quote
  #19  
Old 03-26-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
anyone else have any ideas to try b4 i go and spend a **** load of money
Reply With Quote
  #20  
Old 04-15-2008
Downey's Avatar
RF Veteran
Thread Starter
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
????
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
WTH!!: Analog to Digital switch is messin w/ my Ranger radio! dixie_boysles Audio & Video Tech 18 06-12-2009 01:37 PM
Wth cant i get home? edgeman4.0 Ranger-Forums Office 5 05-15-2009 07:21 AM
WTH!!! xRedGTx General Ford Ranger Discussion 6 05-10-2009 07:59 PM
Is there a FW 8.8 wth disc brakes? alljackedup Suspension Tech 11 07-20-2008 03:09 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:08 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.