IAC problem ? - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-31-2010
Member
Thread Starter
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
IAC problem ?

I am thinking its an IAC issue after reading through the other posts. Just wanted some agreement before I pull this one and clean it / order a new one...


OK.... 2003 Edge 4.0 with 5 speed auto...

Sometimes when I am backing into my driveway I stop in the street and put it in reverse, it dies.
Sometimes I get it into the parking spot and when I go from R to P it dies.
It doesn't happen every time, just sometimes and it's finally time for me to do something about it.
I've been holding out on changing the plugs and coils until I install the BL, and looking for a better alternator as well .

As lucky as I have been with the truck (surviving 5 years as the wife's dd - thats a miracle in itself) Have never had any real problems other than the stupid elbow and only changing the battery , front brake pads, tires, and (sometimes) regular oil changes with oil / air filters and thats really it. I still average 20 - 22 mpg every tank. I drive 99% highway @ 60 - 70 mph. I only spend about 1 mile of city driving... I have no complaints on the power . It runs fine all the time except when I try and park at home... I seriously mean no real maintenance ( ALL factory **** in it still with 124,000 miles )

Thanks...
Reply With Quote
  #2  
Old 04-09-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
is your check engine light on because a bad IAC will throw a code
Reply With Quote
  #3  
Old 04-09-2010
powerranger262's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2009
Location: Hartford, WI
Posts: 1,222
Just take it out and clean it, takes a couple minutes, and it will help.
Reply With Quote
  #4  
Old 04-09-2010
Member
Thread Starter
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
No check engine light, but since it dies i usually just restart and do what I have to.. Will clean it and check for loose connections everywhere
Reply With Quote
  #5  
Old 04-09-2010
leadfoot's Avatar
Member
 
Join Date: Oct 2007
Location: MA
Posts: 894
Quote:
Originally Posted by djfllmn View Post
is your check engine light on because a bad IAC will throw a code
mine never did, but it was stuck at a 2000RPM idle.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
IAC problem sajo99 SOHC - 2.3L & 2.5L Lima Engines 2 01-04-2011 11:01 AM
IAC Problem ZWilson07 General Ford Ranger Discussion 11 05-04-2010 09:08 AM
IAC problem t5cents 2.9L & 3.0L V6 Tech 20 03-07-2009 08:20 PM
IAC valve problem. jdpartsman99 4.0L OHV & SOHC V6 Tech 11 08-24-2007 05:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:05 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.