IAT Sensor Test. Need some advice. - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-17-2014
ThEgoldRanger's Avatar
Member
Thread Starter
 
Join Date: Nov 2013
Location: Labette, Ks
Posts: 29
Icon4 IAT Sensor Test. Need some advice.

I got bored the other night and tested my connections under the hood and all was good til I got to the IAT sensor. 12v dc I did red positive to wire and black ground to the battery and got 4.6v. Did the other test where you should be getting somewhere in 4v range it popped up .04 - .06? Turned my ignition over to see if change but no stayed the same and did test with hooked up and got same .04 - .06v. Is this correct or is it messed up? Any tips would be great.
Could it be bad wiring or bad sensor? Let me know thanks(:
Reply With Quote
  #2  
Old 06-17-2014
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,582
Intake Air temp(IAT) sensor will test similar to ECT(engine coolant temp) sensor.

Both get 5volts from Computer on one wire then that voltage passes thru the sensor's internal resistor circuit and back to the Computer on the other wire.

The Ground on this type of circuit is at the Computer, which in theory will be the same 0volts as the engine block but it can read slightly different.

The 5volts on the one wire can read 4.5v to 5.0v
The "return" wire volts can read .2v to 3.5v
The lower the "return" volts the warmer the temp

On your '99 the IAT sensor should be part of the MAF sensor(6 wire MAF)
Reply With Quote
  #3  
Old 06-17-2014
ThEgoldRanger's Avatar
Member
Thread Starter
 
Join Date: Nov 2013
Location: Labette, Ks
Posts: 29
No the maf and iat are separate
Reply With Quote
  #4  
Old 06-18-2014
ThEgoldRanger's Avatar
Member
Thread Starter
 
Join Date: Nov 2013
Location: Labette, Ks
Posts: 29
Any more ideas?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
IAT sensor chip spec_ops57 General Technical & Electrical 26 02-29-2016 11:35 AM
Coil Pack/IAT Sensor Questions Froggmann 2.9L & 3.0L V6 Tech 0 04-08-2012 08:47 PM
iat resistor 98 ranger SOHC - 2.3L & 2.5L Lima Engines 1 10-08-2009 12:38 AM
IAT mod on FFV engines -- doesn't work properly n3elz 2.9L & 3.0L V6 Tech 29 03-08-2005 12:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:44 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.