Im having a miss in my 94' 4.0 - Ranger-Forums - The Ultimate Ford Ranger Resource

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Im having a miss in my 94' 4.0

Reply

 
 
 
  #1  
Old 07-16-2010
Member
Thread Starter
Join Date: Jul 2010
Location: Grundy, TN
Posts: 20
Icon4 Im having a miss in my 94' 4.0

Im having a miss with my 4.0 when you first give it gas and some times it want start unless you hold it to the floor. I also think it idles high too. It idles around 1500 to 2000 rpm's. Does anybody have any ideas or hints what might be wrong?
 
Reply With Quote
  #2  
Old 07-20-2010
ccosgrove71's Avatar
Member
Join Date: Jun 2010
Location: richmond,va
Posts: 185
it sounds like a major vacuum leak.
 
Reply With Quote
  #3  
Old 07-20-2010
Member
Join Date: Jul 2010
Location: nederland,tx
Posts: 14
engine light on?
 
Reply With Quote
  #4  
Old 07-20-2010
Member
Thread Starter
Join Date: Jul 2010
Location: Grundy, TN
Posts: 20
Yeah it is but I cant figure it out.
 
Reply With Quote
  #5  
Old 07-21-2010
ccosgrove71's Avatar
Member
Join Date: Jun 2010
Location: richmond,va
Posts: 185
do you have a code reader?
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Arkountryboy
General Technical & Electrical
7
03-10-2016 07:24 PM
budbaringer
General Technical & Electrical
0
04-17-2007 07:56 AM
zabeard
General Ford Ranger Discussion
39
02-21-2007 11:11 PM
crazy wheelerman 730
2.9L & 3.0L V6 Tech
3
02-26-2006 09:12 PM


Thread Tools
Search this Thread
Quick Reply: Im having a miss in my 94' 4.0


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.