4.0 engine miss possible electrical??? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-17-2007
Member
Thread Starter
 
Join Date: Mar 2007
Location: Bellefontaine, Ohio
Posts: 6
4.0 engine miss possible electrical???

Hi All,
Newby here, name is Bud

I have recently completed a motor swap on a 94 4x4 Ranger and something is not correct. The original motor was a 4.0 and the donor vehicle was a 93 4x4 with a 4.0 so I figured this was a no brainer...... Oppsy.........
The trannys are the same (both AL4D) and all accessories A/C Alt etc were kept with the original motor and just dropped in the whole ball of wax....
The first test drive I noticed some really poor performance in the mid power range and somewhat poor everywhere. Checked the Engine control computers and noticed they were different versions. Swapped the computers and performance made a marked and very noticeable improvement but still not at 100% especially in the 1/2 to 3/4 power band At times it will take off and run perfect. But soon it will revert to less than perfect, for no apparent reason..... It also feels as though there is a pronounced miss in the motor most of the time, if I mash the pedal it usually helps but then starts missing again when I back off it. I have not been able to get any real pattern to it all, except it always starts to miss again once I back off the trottle all the way. My last test drive I also noted the temp gauge started varying quite a bit, up all the way, then back to the middle and so on? I checked my coolant and it is full, no aparent leaks...... Any help out there?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Engine miss rangermark General Ford Ranger Discussion 0 01-31-2010 08:42 AM
94 4L engine Swap Strange Electrical Problem HELP ggadwa General Technical & Electrical 0 11-12-2009 12:44 PM
Freaky engine miss rangermark General Ford Ranger Discussion 5 09-25-2009 01:42 AM
Engine miss wtk General Technical & Electrical 1 11-28-2007 10:11 AM
Engine seems to miss ? crazy wheelerman 730 2.9L & 3.0L V6 Tech 3 02-26-2006 09:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:53 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.