Just bought this truck HELP! - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 05-06-2010
--weezl--'s Avatar
Member
iTrader: (1)
 
Join Date: Sep 2009
Location: Calgary AB, Canada
Posts: 3,139
then it's not burning it... you are either leaking coolant, or you are getting air bubbles out of the system
Reply With Quote
  #27  
Old 05-06-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
Got pics of the tranny pan when I took it off...

Name:  IMG_0198.jpg
Views: 0
Size:  109.4 KB
Name:  IMG_0199.jpg
Views: 0
Size:  149.1 KB
Reply With Quote
  #28  
Old 05-06-2010
pcollins's Avatar
Member
 
Join Date: Apr 2010
Location: Walworth, NY
Posts: 493
Ooooh look at all the shiny metal chips! (thats not good by the way. lol) did you dump that in your kitchen sink? shame on you.

we burn it.....lol
Reply With Quote
  #29  
Old 05-06-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
Still wont shift into 4th
Reply With Quote
  #30  
Old 05-06-2010
pcollins's Avatar
Member
 
Join Date: Apr 2010
Location: Walworth, NY
Posts: 493
stolen from explorer forum:

Quote:
The PCM commands the overdrive solenoid, so sensors such as the TPS, MAF or the VSS could be malfunctioning. Check the overdrive solenoid through the internal wiring harness, and the overdrive band with the adjustment stud. The servo could be bad, and would need to be replaced if it's dried out.
Reply With Quote
  #31  
Old 05-06-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
How...?
Reply With Quote
  #32  
Old 05-06-2010
pcollins's Avatar
Member
 
Join Date: Apr 2010
Location: Walworth, NY
Posts: 493
well, there are individual test for the TPS-throttle position sensor, MAF- mass air flow, and VSS- vehicle speed sensor. I'm sure another member here can point you to how to test those. in order to test the overdrive solenoid the tranny pan must be off.
Reply With Quote
  #33  
Old 05-06-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
Figures AFTER i put the new gasket on.
Reply With Quote
  #34  
Old 05-06-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
If theres a screen in there Im sure its clogged

VSS... The speedometer kinda bounces alittle...
Reply With Quote
  #35  
Old 05-06-2010
pcollins's Avatar
Member
 
Join Date: Apr 2010
Location: Walworth, NY
Posts: 493
if you havent taken it off yet dont, get all the other tests done first before you yank the pan again.
Reply With Quote
  #36  
Old 05-07-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
Well I know the MAF sensor is workingbecause when I take off the intake tube that connects it tot he throttle the check engine light comes on. Connect it back and it goes off.
Reply With Quote
  #37  
Old 05-07-2010
pcollins's Avatar
Member
 
Join Date: Apr 2010
Location: Walworth, NY
Posts: 493
but did you test it with a volt meter and take it off to see if its dirty, or the little wire that gets hot is busted?
Reply With Quote
  #38  
Old 05-07-2010
Member
 
Join Date: Mar 2010
Location: white oak tx
Posts: 237
did you check the turbo encabaculater?

also check your oil for water thats one place it might be going if there is water it will be a milky color
Reply With Quote
  #39  
Old 05-08-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
No water in the oil or tranny fluid that I can tell but I think the rad cap needs replaced.
Reply With Quote
  #40  
Old 05-08-2010
Tys 4x4 FTW's Avatar
RF Veteran
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
sounds like you paid a bit too much for a POS truck..
Reply With Quote
  #41  
Old 05-08-2010
Member
Thread Starter
 
Join Date: May 2010
Location: Webster, Tx
Posts: 17
Told myself years ago that I would never owen another POS ford becaseu EVERY one ive ever owned was junk. Hell I even had one put its self into gear and take off acoss the parking lot.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Just bought 99 Ranger, Gas Mileage stinks but love the truck. cfigurelli Member Introductions 3 09-28-2010 02:55 PM
My new truck i just bought. 93 xlt 4.0 Snapshots 4 06-29-2010 12:43 PM
Just bought my first truck! Traveler5 Member Introductions 18 04-01-2008 09:07 AM
New here just bought a truck. dgrier87 Member Introductions 16 12-12-2007 12:11 AM
Just bought my truck's official first mod... l2en General Technical & Electrical 34 09-05-2006 09:28 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.