Need the great Ranger Guru's help Eng light issue - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-29-2011
squrll's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: fairfax va
Posts: 191
Need the great Ranger Guru's help Eng light issue

Ok I have been trying to get this dam check eng, light off in my truck for weeks

Let me start at the begining I had something break loose in my Cat. and it rattled all the time internally not the shield so I replaced it with new, While it was off the truck I had to move the truck in and out of the garage so Check Eng light came on. installed new cat and reset light and all good for about 3 weeks
'
Then light came on again this time I checked codes PO171 and PO174
Fuel trim Bank one and two Lean condition.


I have replaced both o2 sensors uppers on bank 1 and 2
replaced all spark plugs
clean air filter , Cleaned Mass air flow
replaced PVC
have run a can or 2 of injector cleaner through the tank
It is driving me crazy now I need to get through emmisions to get new tags
any idea can't keep spending money and not fixing the issue

Every time I reset the code before I did new plugs, light would stay off for a least three start cycles, now it comes on in about 4 mins

It could be fuel pressure is low but the truck really runs so good I am baffled I wonder if the new cat convert is bad I am almost to the point of reinstalling the old one and see if the light goes out.


Anyone have any idieas
HELP
Reply With Quote
  #2  
Old 08-29-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
Using the search button at the top of the pane and entering "p0171 p0174" I got three pages of threads.
Surely your answer must be in there somewhere.
Reply With Quote
  #3  
Old 08-30-2011
squrll's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: fairfax va
Posts: 191
yeah I have read those threads they all seem to jump around and not really giving a answer to the question as to what fixed the problem
Reply With Quote
  #4  
Old 08-30-2011
brichmond's Avatar
Member
 
Join Date: Dec 2006
Location: IA
Posts: 116
cats wont cause lean codes. if they were pluged it would cause a rich code. u have to have a vacuum leak, mass air flow, low fuel pressure possibly. these are about the only thing that can cause both banks to throw these 2 codes at the same time.
Reply With Quote
  #5  
Old 08-31-2011
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
While checking some past threads one thing stuck out.
4.0s seem to like to loosen the intake bolts quite a bit. Check to make sure they are tight.
Reply With Quote
  #6  
Old 08-31-2011
Member
 
Join Date: Aug 2011
Location: Rush, PA
Posts: 8
I had the same set of problems early on as well, test your EGR valve, It did the trick for me for a long while. and it never hurts to check your fuel pressure. you can rent the tool from o'rileys or autozone
Reply With Quote
  #7  
Old 09-01-2011
squrll's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: fairfax va
Posts: 191
Sorry guys must have tyoe in the wrong Code the 1st time I searched after OTRtech reply I went back and researched again found it to be the same problem everyone else has been having. Thanks foe sending me in the right direction Ken Appeicate it.
Reply With Quote
  #8  
Old 09-01-2011
squrll's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: fairfax va
Posts: 191
here is the culprit Light is out and codes are gone,
Attached Thumbnails
Need the great Ranger Guru's help  Eng light issue-dscf3258.jpg  
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil Drain Plug May Be Stripping - 1998 2.5 4Cyl Eng - PLEASE HELP ! saxtech General Ford Ranger Discussion 4 06-26-2012 12:56 PM
'97 Ranger 4.0 Check Eng Problem Rvroby 4.0L OHV & SOHC V6 Tech 2 03-09-2011 07:44 PM
Check Eng Light (CEL) tj2245wz General Ford Ranger Discussion 4 09-29-2007 05:41 PM
need help with e-fan....calling all electrical guru's.. TippnOver General Technical & Electrical 12 11-10-2005 02:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.