problem solved... - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-24-2008
Member
Thread Starter
 
Join Date: Jan 2007
Location: Columbus, IN
Posts: 53
problem solved...

After fighting my truck to figure out why it runs like hell and gas mileage has gone south, we may finally have an answer. About 2 weeks ago my wife was driving it and called me and said it was bucking, jerking and had a god awful noise coming from it. Turns out one of the rear brakes was hung and had been dragging & completly wore out a brake shoe to the point what was left of the pad fell off and wedged itself in the drum. The other side looked almost brand new. 3 hours and $20 later its fixed and immediately noticed an increase in mpg. My friend that helped me also recommended an old school mechanic, one who doesn't just stop at looking for codes then saying 'its fine' when nothing turns up. He found a leak in the upper intake manifold gasket. It will be taken in next week to be fixed. Hopefully this will take care of everything. Thanks to everyone who's helped.
Reply With Quote
  #2  
Old 04-24-2008
My91Ranger's Avatar
Member
iTrader: (1)
 
Join Date: Apr 2007
Location: Roseville, Michigan
Posts: 2,252
glad to hear you got it fixed and it wasn't to much trouble or money
Reply With Quote
  #3  
Old 04-24-2008
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
ha i have a similiar situation i took my truck to get inspected and found out i had an axle seal leaking
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What Solved The Problem vstar650ca General Ford Ranger Discussion 1 02-05-2014 10:59 AM
4.0 sparkplug problem solved Bronco billy 4.0L OHV & SOHC V6 Tech 5 02-05-2014 12:02 AM
A/C Compressor Problem Solved bikkabee DOHC - 2.3L Duratec / Mazda L Engines 3 02-14-2011 11:29 AM
Leaking Hurst Shifter - Problem Solved FullThrottle02 Drivetrain Tech 13 10-18-2009 05:47 PM
Shift Problem Solved! helievacpilot Drivetrain Tech 2 03-06-2008 06:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:33 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.