Rough Shifting after intake manifold gasket replacement - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-18-2012
Member
Thread Starter
 
Join Date: Apr 2012
Location: Colorado Springs, Colorad
Posts: 2
Rough Shifting after intake manifold gasket replacement

Hey there guys/gals,

I replaced my intake manifold gaskets two weeks ago. Right after I drove out of the garage, I started having a rough shift from 1-2 and 2-3. The problem wasn't happening before I changed out the gaskets. It happens every time I go 1-2 and 2-3.

I've checked all the hoses to make sure everything is back in place. I ran a diagnostic before changing out the gaskets, and it threw some codes saying to replace the EGR pressure sensor, downstream o2 sensor and fuel filter.

Any advice as to why i would be having this shifting problem all of a sudden? Think that if i replace all of the other codes that were thrown and the spark plugs it might solve the issue? I reckon i'm just trying to get a piece of mind that it's not a tranny problem. I don't see how it would being that it only started after replacing the intake manifold gaskets.

It's on a 2002 4.0 sohc 4x4 ranger.

Thanks so much for your help!
Reply With Quote
  #2  
Old 04-18-2012
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
How far did you drive it? After a battery disconnect, the PCM has been reset and its memory erased. It takes some driving to relearn the correct pressures for consistent/smooth shifts.
Reply With Quote
  #3  
Old 04-19-2012
Member
Thread Starter
 
Join Date: Apr 2012
Location: Colorado Springs, Colorad
Posts: 2
thanks for your response!

i've driven it a couple of days to work. work is an 11 mile commute, so i would assume it would have reset by now.

any other thoughts?
Reply With Quote
  #4  
Old 04-19-2012
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
Are the MAF and TPS connectors fully seated?

Unmetered air leaks between the MAF and the throttle body?

Any new trouble codes?

Last edited by V8 Level II; 04-20-2012 at 07:32 AM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Intake manifold bolts loosen after lower gasket change? BL00DPIG 4.0L OHV & SOHC V6 Tech 7 10-06-2014 11:29 AM
Rough Acceleration/Idle after Intake Manifold replacement gwillakers General Technical & Electrical 2 10-08-2012 01:13 PM
Lower Intake Manifold Gasket Replacement jbmcquade General Ford Ranger Discussion 3 04-17-2011 03:44 PM
Intake Manifold Gasket/Intake Manifold fordboston 4.0L OHV & SOHC V6 Tech 6 01-25-2010 10:37 PM
Intake Manifold Gasket Install - Use RTV too? R Carson 2.9L & 3.0L V6 Tech 3 04-01-2009 06:44 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:15 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.