runs very rough? help - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-30-2012
Member
Thread Starter
 
Join Date: Nov 2011
Location: Louisburg
Posts: 26
Icon4 runs very rough? help

hey everyone. having trouble with my 4.0. just had the upper intake manifold gaskets replaced 2months ago. close to hitting 200,000. shes been running fine except today. i drove it for about 8 miles and parked it. cranked it up about 5 hours later and it idled very rough. i figured it would go away after it warmed up.. but it didnt. engine vibrates under acceleration. especially uphills. it like stalls or skips. check engine light started blinking. also noticed a small water puddle under it the other day. coolant levels seem fine. internal leak? distributor? thanks you guys
Reply With Quote
  #2  
Old 12-01-2012
PAShooter's Avatar
Member
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Sounds like a miss, check spark plugs/wires first. then move to the coilpack. if theyre all in fine shape it may be an injector. Take it to autozone and get the code pulled, it will say which cylinder is missing. Look for where its leaking. An internal leak like a headgasket wouldnt make a puddle...
Reply With Quote
  #3  
Old 12-01-2012
Ardy's Avatar
Member
 
Join Date: Aug 2010
Location: Windsor NS
Posts: 276
When was the last time you changed your plugs? Loss of spark / misfire sounds like the issue you're having - if you haven't replaced them you probably should.
Reply With Quote
  #4  
Old 12-03-2012
Member
Thread Starter
 
Join Date: Nov 2011
Location: Louisburg
Posts: 26
yes they are only a month or two old tops. i was thinking fuel pump. im not a mechanic so not too mechanically inclined. i was told head gasket from a friend and it had me paranoid. its not showing signs for a blown head gasket. nor has it overheated. would it hurt it to drive it 8 miles to my nearest autozone?
Reply With Quote
  #5  
Old 12-07-2012
Member
 
Join Date: May 2012
Location: Walnut Creek, California
Posts: 17
If it runs and doesn't overheat 8 miles shouldn't be too far. Take it, maybe see if one of the employees can take a "smoke break" and give you some input.
Reply With Quote
  #6  
Old 12-07-2012
oldblue01's Avatar
Member
 
Join Date: Jul 2012
Location: Venango, PA
Posts: 375
Like the others said, sounds like a miss. If I remember right that's what the blinking CEL means. And yeah, getting a code will help you figure out where to start. Otherwise you're going on a wild goose chase because you don't know which cylinder has the miss.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Starts up rough, Runs, then dies...HELP! ReefSki 4.0L OHV & SOHC V6 Tech 2 11-12-2013 10:16 PM
Engine runs rough. NEED HELP DangerRanger96 SOHC - 2.3L & 2.5L Lima Engines 8 09-08-2012 06:04 PM
95 2.3L Suddenly runs BAD! HELP! Idles rough, no power. jtt3769 SOHC - 2.3L & 2.5L Lima Engines 7 07-25-2008 10:29 AM
Very, VERY tempting.... Fx4wannabe01 General Ford Ranger Discussion 18 04-25-2007 09:32 AM
Very very angry!!!! Werty Interior Semi-Tech 34 04-08-2007 08:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:33 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.