Slight Engine Tick and Lean Codes - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-23-2012
Member
Thread Starter
 
Join Date: Nov 2011
Location: Louisburg
Posts: 26
Icon4 Slight Engine Tick and Lean Codes

(1997 4.0 ohv) okay so yesterday i drove through a drive-through and noticed a slight tick of the engine. (i had the windows down and no AC or heat on) almost like a pen being clicked. seems like it keeps pace with the rpms. the truck has also been throwing lean codes. she only does it when the engine is hot and at idle. cold she idles without a tick. its very annoying and drives me crazy even though it is quiet. any ideas or suggestions since im a newbie mechanic? any help is appreciated.
Reply With Quote
  #2  
Old 07-24-2012
Naughton's Avatar
Member
 
Join Date: Jun 2010
Location: FL
Posts: 313
The 4.0 is naturally a noisy engine, and the tick is just the valve train. As for the lean codes the first things I would check/replace is the MAF and the fuel filter.
Reply With Quote
  #3  
Old 07-26-2012
Member
Thread Starter
 
Join Date: Nov 2011
Location: Louisburg
Posts: 26
thanx man took a little of my shoulders..And unfortunately I have already cleaned the MAF and airbox pretty good. Also replaced my fuel filter. Might check for vac. Leaks or check my intake manifold. Upstream O2 sensors maybe? Anyone who had these damn lean codes and fixed them I'd like to here your input.
Reply With Quote
  #4  
Old 07-26-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
lean and a tick can be a bad injector.
Reply With Quote
  #5  
Old 07-26-2012
bfd's_ranger's Avatar
Level I Supporter
 
Join Date: Feb 2010
Location: Vancouver island B.C.
Posts: 225
If your getting lean codes on both banks then it's your intake gaskets.
Reply With Quote
  #6  
Old 08-29-2012
Member
Thread Starter
 
Join Date: Nov 2011
Location: Louisburg
Posts: 26
getting **** poor gas milage.. also a slight smell of gas do you think it could be the injectors also? she idles VERY rough until its warmed up. ive cleaned IAC, MAF, and replaced fuel filter and problem is still there. want to know anything else before i start throwing parts at it.
Reply With Quote
  #7  
Old 09-01-2012
bfd's_ranger's Avatar
Level I Supporter
 
Join Date: Feb 2010
Location: Vancouver island B.C.
Posts: 225
Gaskets man
Reply With Quote
  #8  
Old 01-21-2013
Member
 
Join Date: Mar 2010
Location: Roy, Utah
Posts: 25
I had a crack in the crook of the "Y" exhaust pipe which caused both banks to read lean. Good luck.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Tick tick tick Konkopito 4.0L OHV & SOHC V6 Tech 5 11-18-2014 07:43 PM
2010 Ranger regular cab XL 4 cyl slight lean... Normal?? 2010 Suspension Tech 6 09-23-2010 11:58 PM
check engine light /// evap code and 2 lean codes 4x4ranger 4.0L OHV & SOHC V6 Tech 0 02-16-2010 07:10 AM
running lean codes and stalling skyway0018746 4.0L OHV & SOHC V6 Tech 26 04-25-2009 03:20 PM
lean bank 1 / lean bank 2 acxlt01ranger4x4 4.0L OHV & SOHC V6 Tech 4 06-24-2006 07:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.