Temp gauge starts in the middle stays on H - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-22-2014
Member
Thread Starter
 
Join Date: Mar 2014
Location: North Carolina
Posts: 3
Temp gauge starts in the middle stays on H

I have a 2004 Ford Ranger FX4 Level II 4x4 4.0 v6 and the temp gauge is acting up. From a cold start the temp gauge starts just below halfway between cold and hot, then within a minute or so it is on H. I changed the two temp sensors and that didn't do anything. Thermostat is next but I'm almost 100% that won't do the trick. I'm thinking the gauge is set wrong. Like it's starting place is in the middle not the very bottom, although when the truck is off it drops below C like it should.

thanks for any help
Reply With Quote
  #2  
Old 03-22-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
the temp gauge needs reset by a ford diagnostic computer
Reply With Quote
  #3  
Old 03-22-2014
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,586
Disconnect the 1 wire on the sender, dashboard gauge uses a 1 wire sender, not to be confused with the 2 wire "sensor" the computer uses, they look similar.

With the 1 wire disconnected turn on key, see where needle is.
Now ground that 1 wire and see where needle is.
You should get full motion of needle, all the way up and all the way down then gauge and wire are OK, if it is ever sitting in the middle then yes gauge or wire to gauge is the issue.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Just a middle aged man with a middle aged dog. Natural Light Member Introductions 0 09-01-2014 10:00 AM
Gas Gauge and temp gauge help!! T12icky0 General Technical & Electrical 1 02-14-2013 03:41 PM
Oil light stays on until engine hits full operating temp, used to do the opposite BuckGodot 2.9L & 3.0L V6 Tech 1 02-17-2012 05:16 AM
Engine starts choking and misfires then starts to jerk violently 97ranger666 SOHC - 2.3L & 2.5L Lima Engines 3 10-09-2011 12:36 PM
Temperature gauge stays in the red? 95Rangerjunkie SOHC - 2.3L & 2.5L Lima Engines 5 09-13-2008 01:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.