upper rad hose - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-13-2009
JRacer's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: May 2008
Location: Watson, Louisiana
Posts: 1,085
upper rad hose

My truck has been leaking coolant where the upper hose connects to the rad. I removed the hose and the neck isn't dented up at all. I bought a new hose and hose clamp. Still does it. So i just got bak inside from putting rubber sealant around where it connects and i topped off the rad with some water. Has anyone else figured out a better solution for this? O, and a nice story: On the way to work today the truck decided to run hot so i had to pull over and fill up the rad and it did fine for the twenty minute ride to work. Well, i got to work and we werent busy at all so i popped my hood and looked at the hose and while i was lookin a fella driving a dump truck jus got through dumping a load rite next to the parkin lot i work in and he asked if i needed any help. I told him the stituaion and he gave me some options and i had tried all of them already but i was amazed that he stopped and asked if i needed some help. Nice guy i guess. Well i ended up putting some silicone around it and that got me bak home at least, but it still leaks. Sorry for the story, jus thought i would share.
Reply With Quote
  #2  
Old 01-14-2009
Member
 
Join Date: Sep 2007
Location: North Liberty, Iowa
Posts: 35
Look for a crack in the part of the radiator where the hose connects. Fill the radiator with the engine cold, start the engine & wait 3-4 minutes. Look closely with a good light. I bet you will find a crack that is leaking. If you can't find it near the hose, look down both sides of the radiator. Hope you find it!
Reply With Quote
  #3  
Old 01-14-2009
JRacer's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: May 2008
Location: Watson, Louisiana
Posts: 1,085
well i know for sure there is no cracks. Did the test. If i feel under the hose i can feel about where the water is coming out. I dont understand why that sealant didnt work. Is there anything else i could put around the hose?
Reply With Quote
  #4  
Old 01-15-2009
JRacer's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: May 2008
Location: Watson, Louisiana
Posts: 1,085
well i fixed it tonite. i peeled off the silicone and pulled the hose bak a little and tightened down the clamp and walah. It doesnt leak anymore (knock on wood).
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
collapsed upper radiator hose dave89b 4.0L OHV & SOHC V6 Tech 2 07-16-2010 03:47 PM
Top hose warm, bottom hose cold. Thermostat? wesleyn 2.3L & 2.5L I4 Tech 6 01-05-2009 08:13 AM
Flat rad. hose schatten789 2.9L & 3.0L V6 Tech 6 06-30-2008 06:44 AM
'96 2.3L Upper radiator hose issue - has this happened to you? UndrTheInfleunce SOHC - 2.3L & 2.5L Lima Engines 4 08-06-2006 07:49 PM
Upper radiator hose sliced Diabolic SOHC - 2.3L & 2.5L Lima Engines 2 12-08-2004 01:29 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.