'96 2.3L Upper radiator hose issue - has this happened to you? - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-16-2006
UndrTheInfleunce's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: Tucson, AZ
Posts: 1
'96 2.3L Upper radiator hose issue - has this happened to you?

hey i have a 96 ford ranger xlt with a 2.3L engine. I went to check the fluids the other day and I had no coolant. It was weird so I checked the radiator hoses and it turns out it got cut by the A/C compressor. Is this just my ****ty luck or is it a general issue?
Reply With Quote
  #2  
Old 07-17-2006
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
must not have been installed right... there should be plenty of room for the hoses. ive never heard of anyone having hose issues that werent caused by improper use or a poor quality hose.
Reply With Quote
  #3  
Old 07-17-2006
Mike9825's Avatar
Member
 
Join Date: Jun 2006
Location: Willard OH
Posts: 489
wow that is weird. I'm with tireiron here. I'm inclined to think you might have the wrong hose on there. check the part# on it then have a local parts store cross reference that number and install the proper hose. -Mike-
Reply With Quote
  #4  
Old 08-06-2006
rangerdan01's Avatar
Member
 
Join Date: Jun 2006
Location: Apex, NC
Posts: 359
ive had this problem twice they make the hoses too big all you need to do is cut off about a 1/2'' to 3/4'' and it will work
Reply With Quote
  #5  
Old 08-06-2006
Diabolic's Avatar
Member
 
Join Date: Sep 2004
Location: Rising Sun, MD
Posts: 1,542
haha, i replaced mine too. Turn the hose around so the bend doesnt touch the belt. Thats the way it was on my gen4 (2.5)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
98 Ranger 2.5L upper radiator hose hard Starchief64 SOHC - 2.3L & 2.5L Lima Engines 3 01-04-2015 01:14 PM
Upper Radiator hose collapses under throttle? that.minitrucker General Technical & Electrical 6 09-24-2011 09:12 PM
radiator hose issue lifted_Mazda01 2.9L & 3.0L V6 Tech 2 12-17-2010 09:08 AM
collapsed upper radiator hose dave89b 4.0L OHV & SOHC V6 Tech 2 07-16-2010 03:47 PM
Upper radiator hose sliced Diabolic SOHC - 2.3L & 2.5L Lima Engines 2 12-08-2004 01:29 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.