Water pump leaking - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-22-2009
wydopnthrtl's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
Water pump leaking

I must say that overall I like my ranger. Quite a bit actually.. but there have been several quality issues.

The truck now has 50k on it. And last winter in the snow I noticed a few drops of antifreeze. I saw the leak path was from the water pump.
So I figured as long as it wasn't puddling or loosing too much coolant I'd let it go. Well I was changing fluids yesterday and now it's leaking more. The front of the engine is damp and I have yellow/green drops hanging everywhere.

IMO.. a newer car w/less than 50k miles on it should not have water pumps, brakes, IAC, go out.. and fluids that are black.

Just a bit of a rant I reckon.. Looks like I'll be changing the water pump next weekend on a ford I bought new... 26 months ago.
Reply With Quote
  #2  
Old 03-23-2009
Bryan22's Avatar
Member
 
Join Date: Nov 2008
Location: Lancaster, ca
Posts: 211
no warranty?
Reply With Quote
  #3  
Old 03-23-2009
graniteguy's Avatar
Member
iTrader: (3)
 
Join Date: Jul 2005
Location: Texas
Posts: 3,221
my 2004 4.0 did the same at about the same mileage (coming out the weep hole).
Reply With Quote
  #4  
Old 03-23-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
And people wonder why I want to sell my truck.
Reply With Quote
  #5  
Old 03-23-2009
wydopnthrtl's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
Bought a new airtex pump tonight. It'll go in this weekend.

Oh and another failure I forgot to mention. One that left me on the side of the road in -3F weather at mid-night too! Can't believe I forgot this one.. the clamps on the tranny cooler broke in 1/2.

I had picked up a friend at the airport for the 2009 NAIAS. We were about 4 miles from the house running 70mph on the freeway.. and all of a sudden I had no forward power. Nothing at all. Pull over, get out, and there is tranny fluid everywhere! Yeah.. that was fun. I'd have thrown it up as a fluke.. except when I got it home I found that one of the other clamps had broke too. That right there is a factory defect. Thanks papa ford.

Rich
Reply With Quote
  #6  
Old 03-23-2009
wydopnthrtl's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
Quote:
Originally Posted by Bryan22 View Post
no warranty?
I'm beyond warranties. Even if it was still under.. I'd do it myself just to save the heartache and time off work.

Rich
Reply With Quote
  #7  
Old 03-23-2009
exploder01's Avatar
Member
 
Join Date: Aug 2007
Location: Valois, N.Y.
Posts: 143
Just a heads up go ahead and change the thermostat while you got it all apart. I had to take it all back apart because as soon as i started the motor the tstat stuck closed. Just did mine last weekend at 109,000.
Reply With Quote
  #8  
Old 03-23-2009
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
luck of the draw maybe? 110k miles here and have not changed out anything but filters, belts, and spark plugs. mine has been through crap and back more than once.
Reply With Quote
  #9  
Old 03-23-2009
robert99ranger's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
^ I am with Zach. My truck has almost all of the original parts on it except for the normal things to change. I change out the original water pump over christmas break. Nothing wrong with the one just I was in there changing the original timing belt and decided to change the water pump to. I have 133,000. Just crappy luck I guess man. Sorry.
Reply With Quote
  #10  
Old 03-23-2009
07rangersport's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2008
Location: Maple Ridge CANADA
Posts: 800
My waterpump started leaking at 57000km, roughly the same mileage
Reply With Quote
  #11  
Old 03-24-2009
herm59's Avatar
Member
 
Join Date: Jun 2008
Location: Toms River, NJ
Posts: 1,694
guess its the newer trucks w/that problem. Just had mine changed at almost 116,000 and it wasnt leaking, just hanging
Reply With Quote
  #12  
Old 03-25-2009
Alex98's Avatar
Member
 
Join Date: Jul 2007
Location: Baltimore, Maryland
Posts: 844
yea id have to agree no issues here
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Water pump bolts leaking oil? q2quest 4.0L OHV & SOHC V6 Tech 2 11-27-2011 03:50 AM
Water leaking in cab korey89 General Ford Ranger Discussion 16 05-28-2011 10:22 AM
Need Help Water Leaking Into Cab rangerbert 4.0L OHV & SOHC V6 Tech 5 09-17-2008 08:41 AM
Water Leaking into Cab rangerbert Exterior Semi-Tech 6 05-04-2008 12:44 PM
Water pump leaking? fx2offroadranger General Ford Ranger Discussion 16 02-27-2008 06:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.