Weird no power problem 4.0 OHV - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-01-2009
BB2's Avatar
BB2 BB2 is offline
Member
Thread Starter
 
Join Date: Mar 2007
Location: PA
Posts: 333
Weird no power problem 4.0 OHV

My friend has a 94 4.0 5 speed 4x4 ranger and is having a problem with it having no power. It will idle fine but when she goes to pull out, the truck doesn't register her touching the gas. The truck will act like it has no power until she floors it then about a second later it kicks in and takes off. She has replaced the following:

-Air filter
-Fuel filter
-Fuel pressure regulator
-Mass air flow sensor
-Engine coolant temp sensor
-Coolant temp sender
-Tried different TPS and IAC

It still does it and is progressivly getting worse... Any ideas will be appriciated.

Thanks

Last edited by BB2; 06-01-2009 at 07:37 PM.
Reply With Quote
  #2  
Old 06-01-2009
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
tps throtle posion sensor
Reply With Quote
  #3  
Old 06-01-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
x2 on the tps
Reply With Quote
  #4  
Old 06-01-2009
Woods-Rider's Avatar
Member
iTrader: (2)
 
Join Date: Apr 2008
Location: Hillsboro, OR
Posts: 1,108
x3
mine broke a while back
Reply With Quote
  #5  
Old 06-01-2009
BB2's Avatar
BB2 BB2 is offline
Member
Thread Starter
 
Join Date: Mar 2007
Location: PA
Posts: 333
Just talked to her and she said she tried swapping out the tps with another one she had... did the same thing.
Reply With Quote
  #6  
Old 06-01-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
bad fuel pump, fuel pump sending unit? seems logical enough for me. But if the tps was working and there was no fuel getting to the motor the air would choke the motor and kill it?????...maybe a bad throttlebody?
Reply With Quote
  #7  
Old 06-01-2009
BB2's Avatar
BB2 BB2 is offline
Member
Thread Starter
 
Join Date: Mar 2007
Location: PA
Posts: 333
I was thinking fuel pump as well... maybe stuck or something... may be the tb itself but idk if that would do it... I'm stumped
Reply With Quote
  #8  
Old 06-01-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
Id atleast pop the T.B. off and check it, maybe give it a cleanin..make sure the flapper is working
Reply With Quote
  #9  
Old 06-01-2009
BB2's Avatar
BB2 BB2 is offline
Member
Thread Starter
 
Join Date: Mar 2007
Location: PA
Posts: 333
The flapper... i'll definatly check that out lol I just don't want her to throw anymore parts at it.
Reply With Quote
  #10  
Old 06-01-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
No good comes with throwing parts at it. Maybe someone else will chime in who knows better or how to better test parts.
Reply With Quote
  #11  
Old 06-01-2009
pace51's Avatar
Member
 
Join Date: Jul 2008
Location: on da puter
Posts: 711
Ok so I'm not so up on efi's. but a '94 has a throttle cable and so it would not use a tps? right? Maybe it's a bad cable. I know on my '94 150 the throttle sticks every now and then. I get under the hood push it back in then hit it with some wd40, and it'll be ok for a couple months. I know I know I need to put a new cable in.

It could be a bad cable or spring. Checking the flapper also makes good sense. Always try to eleminate things before you go buying parts. Much cheaper that way.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Planning some power mods for my 96 ohv fishy2k8 4.0L OHV & SOHC V6 Tech 8 10-13-2010 05:27 PM
Adding power to the OHV? OVERtheEDGE 4.0L OHV & SOHC V6 Tech 16 08-06-2009 11:22 PM
power steering sound on 4.0 ohv silverbullet32 4.0L OHV & SOHC V6 Tech 6 05-24-2009 11:39 AM
4.0 OHV best power option leadfoot 4.0L OHV & SOHC V6 Tech 3 02-18-2008 09:58 AM
does my 4.0 OHV have the power? God,Country,FORD 4.0L OHV & SOHC V6 Tech 18 12-30-2007 07:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:19 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.