Won't take gas. . . - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-05-2009
FX4BFT02's Avatar
Member
Thread Starter
 
Join Date: Aug 2007
Location: Loganville, GA
Posts: 152
Icon8 Won't take gas. . .

Hey,

I would search but whatever, if any one can help that would be great.

I can't get gas into my tank.. I can get it in little by little.. and when I say little, I mean click by click, second by second.. half a tank in 30 mins! GRR!! It's been this way for three weeks. I start to pump it in at regular speed and it ends up spitting it back out. I've had it shoot out all over me and the bed side. When I release the fuel cap to fill up, there is a lot of pressure release.. There isn't anything stuck in the hose as far as I know.

Soon after this happened, Got the check engine light. It's saying Manufactures code - emissions control.. ??? (related, maybe)

Any help would be greatly appreciated!
Reply With Quote
  #2  
Old 06-05-2009
reader585's Avatar
Member
 
Join Date: Nov 2008
Location: Oromocto New brunswick
Posts: 791
This is messed up, i am going to keep a eye on this thread.
Reply With Quote
  #3  
Old 06-05-2009
"Monster Truck"'s Avatar
Member
 
Join Date: Jan 2008
Location: Cedar Rapids, Ia
Posts: 203
I would say that your breather hose is plugged There should be a hose coming off the neck somewhere it relieves pressure out of the tank when you fill and when your pump sucks it lets pressure in! Its common never this bad though usually chokes engine out first!
Reply With Quote
  #4  
Old 06-05-2009
Djt1994's Avatar
Member
 
Join Date: Mar 2008
Location: Niagara Falls, New York
Posts: 59
you have a venting problem. theres something wrong in your evap system.
Reply With Quote
  #5  
Old 06-05-2009
"Monster Truck"'s Avatar
Member
 
Join Date: Jan 2008
Location: Cedar Rapids, Ia
Posts: 203
The hose will be long btw Most trucks go all the way to the back of the truck!
Reply With Quote
  #6  
Old 06-05-2009
J Hawks8's Avatar
Member
 
Join Date: May 2008
Location: WA
Posts: 76
the breather hose probably is bent or plugged somehow.
Reply With Quote
  #7  
Old 06-05-2009
Machine090767's Avatar
RF Veteran
 
Join Date: May 2006
Location: Minnesota
Posts: 6,410
like the others said "breather hose is plugged or bent"
Reply With Quote
  #8  
Old 06-05-2009
malydeen's Avatar
Member
iTrader: (12)
 
Join Date: Jul 2007
Location: Minneapolis, MN
Posts: 632
Um is the tank full and your gauge wrong?
Reply With Quote
  #9  
Old 06-05-2009
freddie's Avatar
Member
iTrader: (9)
 
Join Date: Apr 2007
Location: OH
Posts: 2,463
Quote:
Originally Posted by Djt1994 View Post
you have a venting problem. theres something wrong in your evap system.
Sounds about right to me...

Isn't this what that canister vent valve thingamajig does?

EDIT: evap canister vent valve
Reply With Quote
  #10  
Old 06-09-2009
Member
 
Join Date: Jun 2004
Location: Corpus Christi, Tx
Posts: 143
Quote:
Originally Posted by freddie View Post
Sounds about right to me...

Isn't this what that canister vent valve thingamajig does?

EDIT: evap canister vent valve
I had the same problem of not being able to to put gas ended up being the evap canister valve. It took ford a month and replacement of everything from the fuel filler neck to the evap canister good it was still under waranty
Reply With Quote
  #11  
Old 06-10-2009
Fenech627's Avatar
Member
iTrader: (1)
 
Join Date: Dec 2007
Location: Detroit, MI
Posts: 908
Is this a hard fix? Probably explains why when I pump gas I have to be really careful where I put the nozzle. The gas pump is always so damn sensitive so sometimes it takes a few tries before I can pump at a steady pace.
Reply With Quote
  #12  
Old 06-13-2009
FX4BFT02's Avatar
Member
Thread Starter
 
Join Date: Aug 2007
Location: Loganville, GA
Posts: 152
Took 20 mins to get half a tank yesterday after work and the trucks driving really rough. I feel like I'm neglecting my truck but I just don't have the money to fix it... Hopefully it isn't choking the engine.... The pressure building up in the gas lines seems to be getting worse.
Reply With Quote
  #13  
Old 06-13-2009
BCobe's Avatar
Member
 
Join Date: Jul 2008
Location: Fairfeild,California
Posts: 1,055
Have you done a BL? If so look a the evap hose like everone has been sayin..
Reply With Quote
  #14  
Old 06-13-2009
OVERtheEDGE's Avatar
Member
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
looks like your gonna need to drop the tank. i would just to check over everything
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
1993 ranger 4x4 4.0 won't take gas xfactor 4.0L OHV & SOHC V6 Tech 0 06-24-2008 09:49 PM
Won't go forward and won't go backwards.. TrishaSB General Technical & Electrical 7 04-14-2006 03:25 AM
to take it or not to take it??????????? blue_bandit General Ford Ranger Discussion 26 02-16-2006 12:31 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.