Need help with wiring problems loading tunes - Ranger-Forums - The Ultimate Ford Ranger Resource

8-Cylinder Tech If you are one of the few with a V8 engine in your Ranger, or if you dream of a Ranger with a V8 engine, this is the sub-forum for you.

Need help with wiring problems loading tunes

Reply

 
 
 
  #1  
Old 05-02-2013
Fordranger1998's Avatar
Member
Thread Starter
Join Date: May 2007
Location: Illinois
Posts: 757
Need help with wiring problems loading tunes

I need to know if anything needs to be repinned on the 42 from the explorer engine harness or ranger side or obd2 port trying to load my custom tune and spent over an hr on phone with sct he said possibly need to swap explorer wiring. Tuner gives me three codes 1019 1017 and 1009.
 
Reply With Quote
  #2  
Old 05-06-2013
Fordranger1998's Avatar
Member
Thread Starter
Join Date: May 2007
Location: Illinois
Posts: 757
Anyone?
 
Reply With Quote
  #3  
Old 05-06-2013
Clinton's Avatar
Member
iTrader: (19)
Join Date: Dec 2010
Location: PA.
Posts: 1,417
I'm a bit confused. Do you have an explorer OBDII on your ranger? Did you do an engine swap, changing the ECM?
 
Reply With Quote
  #4  
Old 05-07-2013
Fordranger1998's Avatar
Member
Thread Starter
Join Date: May 2007
Location: Illinois
Posts: 757
Sorry shoulda put that in 98 ranger has 2001 explorer 5.0 engine harness and ecu are out of the explorer everything else is ranger still
 
Reply With Quote
  #5  
Old 05-07-2013
Clinton's Avatar
Member
iTrader: (19)
Join Date: Dec 2010
Location: PA.
Posts: 1,417
Ok, Did you use the Explorers PCM number for the tune?
 
Reply With Quote
  #6  
Old 05-07-2013
Fordranger1998's Avatar
Member
Thread Starter
Join Date: May 2007
Location: Illinois
Posts: 757
Yes
 
Reply With Quote
  #7  
Old 05-07-2013
Clinton's Avatar
Member
iTrader: (19)
Join Date: Dec 2010
Location: PA.
Posts: 1,417
That's a tough one dude. I wish I could give you the solution, but I think with the mixing of the ranger and explorer harness, something is glitching out. The only thing I could think of is maybe use the rangers PCM code and see what happens.
 
Reply With Quote
  #8  
Old 05-07-2013
Fordranger1998's Avatar
Member
Thread Starter
Join Date: May 2007
Location: Illinois
Posts: 757
It won't crank over either starter don't even click
 
Reply With Quote
  #9  
Old 05-07-2013
Fordranger1998's Avatar
Member
Thread Starter
Join Date: May 2007
Location: Illinois
Posts: 757
anyone have pin diagrams for 42 and ecu and 01 5.0 expo and 42 pin on 98 2.5 ranger?
 
Reply With Quote
  #10  
Old 06-13-2013
Join Date: Aug 2010
Location: Cincinnati, Ohio
Posts: 817
Originally Posted by Fordranger1998 View Post
It won't crank over either starter don't even click
No fuel pulse, and no voltage to the starter you have a pats problem. 2001 expo pcm has pats built in, your 98 doesnt have pats. You need to get a tune to have pats turned off. It will never start until you do. Also, if your able to read the codes with your tuner but not able to download a tune then you either have a problem with your tune or tuner. Pats is your biggest issue at hand. Shouldnt be much to rewire on a 98 but I'd check your wiring manuals if you Have them.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
k.blakeley
Ranger-Forums Office
4
08-10-2011 09:59 AM
0RangerEdge2
Ranger-Forums Office
13
02-17-2009 10:36 AM
jdcrush
General Ford Ranger Discussion
4
05-25-2008 10:55 PM


Thread Tools
Search this Thread
Quick Reply: Need help with wiring problems loading tunes


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.