JL audio xr components suck!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2005
james13f's Avatar
Member
Thread Starter
 
Join Date: Mar 2005
Location: charlotte, nc
Posts: 90
JL audio xr components suck!!!

put one set of them in yesterday (xr-570csi), thank God i compared them to the alpine type-r components before i finished up.

they sound pretty cheap for costing so freaking much.

-the woofer drivers aren't nearly as heavy as the alpine's
-the woofer material doesn't seem to be as high of quality
-the sound is something like thru a barrel compared to the alpine's (better than stock tho)
-the tweeters weren't as heavy, or as powerful (even on same setting as alpines)
-the tweeters mounting parts sucked, the provided screws wouldn't even let you mount the tweeters properly, they stuck out of the mount
-the crossovers were nice, lots of adjustments and pretty good size.

for the $500 retail price, and the $225 i paid on ebay, they are of very poor quality. the alpine's are of much better materials, workmanship, design and sound.

on the up side, the subwoofer (10w3v2) seems to be of high quality. will update when i get a box built.
Reply With Quote
  #2  
Old 04-20-2005
Strider0O0's Avatar
Member
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
where did you put them in, the doors or the rear? make sure your connections are right, and that you've got the speakers crossed appropriately. if you've done that already, you might want to mess with the amp and set it properly as well.. being the same speaker size doesnt mean they'll preform well at the same settings.
Reply With Quote
  #3  
Old 04-20-2005
Member
 
Join Date: Jun 2004
Location: Collinsville, IL (St.Louis)
Posts: 385
are you running them to an amp? Crossovers sound like **** if they are ran from a head unit....JL speakers are actually very high quality and the weight of the speaker doens't necessarily = crap
Reply With Quote
  #4  
Old 04-20-2005
james13f's Avatar
Member
Thread Starter
 
Join Date: Mar 2005
Location: charlotte, nc
Posts: 90
yeah they were running through an alpine v-12 amp, 80w per channel (bridged).

mounted in the door.

i messed around with it quite a bit, but to me they still didn't sound as good as the alpines.

i bought them because everyone told me how high quality stuff jl makes. maybe the alpine's just work better with my setup. or maybe i got a bad pair of jl's. or maybe i was screwing up.

so maybe the sound part was my fault. i dunno, i was probably expecting to much out of them.

i'm going to put them up on ebay if anybody here wants'em.

so if i decide to upgrade later, who makes the best set of component speakers that will fit in our trucks? and where do i find them? diamond is popular on ebay, but i can't find focal or mb quart (upper-end stuff).
Reply With Quote
  #5  
Old 04-21-2005
Strider0O0's Avatar
Member
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
yeah something must be up.. there's no way they should sound like crap.. especially when comparing them to type r's.. like you said.. either the speakers are a bad set, you have something going on wrong, or i dunno.. lol, they just shouldn't be as bad as your stating.

if you got a tweeter (the store) near you, you can check them out.. they're going to be selling Focal soon. mb quart is only in one shop around here, so, i can't help ya there.
Reply With Quote
  #6  
Old 04-21-2005
Member
 
Join Date: Jun 2004
Location: Collinsville, IL (St.Louis)
Posts: 385
Components can be hard to set up to get the sound image just right....are you running them at 4 ohms? Have the "Loud" setting on your HU OFF? Wired correctly?
Reply With Quote
  #7  
Old 04-21-2005
Member
 
Join Date: May 2004
Location: McKinney, TX
Posts: 2,123
They probably just don't have the same sensitivity rating, I.E. The alpines are more efficient an sound better given equal power between the two. That and maybe difference in enclosure made them not sound as good. I'm not a fan of JL however.
Reply With Quote
  #8  
Old 04-21-2005
optikal illushun's Avatar
Member
 
Join Date: Oct 2004
Location: Coal Region, MTC to be exact...heart of the coal region.
Posts: 2,232
arent the JLs power hungry? buddy has some line of JL comps and is feedin them 150W or so rms and says they sound fantastic...
Reply With Quote
  #9  
Old 04-21-2005
detroitmuscle36's Avatar
Member
 
Join Date: Mar 2005
Location: victorville, ca
Posts: 156
about the only thing they amke right is subs. Their speakers absolutely suck and their amps tend to overheat
Reply With Quote
  #10  
Old 04-21-2005
detroitmuscle36's Avatar
Member
 
Join Date: Mar 2005
Location: victorville, ca
Posts: 156
I can get you 6 1/2 Mb Quart for $370 plus shipping. They sound great , my bro has them in his truck, But for the difference in price I'll stick with my alpine's. They don't sound much better
Reply With Quote
  #11  
Old 04-21-2005
Strider0O0's Avatar
Member
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
Quote:
Originally Posted by detroitmuscle36
I can get you 6 1/2 Mb Quart for $370 plus shipping.
which line are they?? Q, Premiem, or Reference?

anyhow, what you said about them being power hungry is partially rght.. they do require a good amount of power to sound powerful. if that is the case, then the MB Quart's are gonna sound just as bad to him.

james, the amp you have for your speakers, its a 4 ch. right?? you were only puttng speakers in the front doors now right, and leaving the rear's empty (thus bridging the amp)? when you said you installed them and listened before you finished up, you didnt just install one did you? you did both doors and then listened right?

EDIT: which model number amp is yours? i know you have a V12, but, that's the series number.. im lookin at them now, is it the MRV-F450?

Last edited by Strider0O0; 04-21-2005 at 12:02 PM.
Reply With Quote
  #12  
Old 04-25-2005
james13f's Avatar
Member
Thread Starter
 
Join Date: Mar 2005
Location: charlotte, nc
Posts: 90
i got the mrv-f450. i have a little over 80w going to the front speakers (bridged over 4 channels, 5th channel is 200w for sub).

rms on the jl's was 70w. i'm going to sell them on ebay. the mounting stuff sucked-*** too. alpine's mounted much better (speakers fit tighter) and the tweeters mounted a lot nicer (mounts aren't super-cheap, actually fit tweeters).

gonna stick with the alpine's for now. out of money for the truck for a while!!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: Polk Audio dxi6500 components, 2 10" dxi 104 subs - IN fishy2k8 Interior, Exterior, Electrical, & Misc. 6 03-12-2012 07:19 PM
For Sale: Polk Audio RM6700 Home Audio Speakers KY straightedge Miscellaneous Items 2 10-09-2009 12:01 PM
KP Components "The rumor is true" Cold_Carcass Suspension Tech 4 03-19-2005 08:18 PM
Wiring Power to various components. FoMoCoFiddy General Technical & Electrical 13 03-10-2005 10:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:29 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.