Odd CD Player Problem - Ranger-Forums - The Ultimate Ford Ranger Resource

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Odd CD Player Problem

Reply

 
 
 
  #1  
Old 11-13-2008
jtfoxman's Avatar
Member
Thread Starter
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Odd CD Player Problem

Hey all. I have a 9 year old JVC KD-S670 in my Ranger. The past few days I've been having a very odd occurance.
I will start the truck and the little red light will come on saying the stereo gets power then I'll turn it on it comes on but keeps turning on and off until finally it shuts down completely. The little red power light stays lit though. It doesn't matter if it's a bumpy road or perfectly smooth road it still does it.
After about 5 min I'll turn it on agin and it will stay on but without sound. I'll wait a minute and turn the volume up and it starts to play and works fine the rest of the day. This all occurs in Radio mode.
I've checked my wires and all all fine, I installed it the correct way with the aftermarket kit for the stereo so there are no splices except for the power and constant and they are connected fine. Is my stereo going or is there something else going on here that i can't see.

Thanks All!
 
Reply With Quote
  #2  
Old 11-14-2008
jtfoxman's Avatar
Member
Thread Starter
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Anyone
 
Reply With Quote
  #3  
Old 11-14-2008
Danger06Ranger's Avatar
Member
iTrader: (-1)
Join Date: Apr 2008
Location: Lowell, IN
Posts: 620
Get a new radio.
 
Reply With Quote
  #4  
Old 11-14-2008
Jp7's Avatar
Jp7
Jp7 is offline
Member
iTrader: (9)
Join Date: Sep 2007
Location: My LED lab or on the dyno
Posts: 2,986
yep i agree with ^ guy. I bought a jvc once, started smoking on day 3.
 
Reply With Quote
  #5  
Old 11-14-2008
DisturbedESV's Avatar
Member
Join Date: Apr 2008
Location: Seattle, WA
Posts: 3,115
I just had stock radios.... when one hit the dirt I went on ebay and bought another stock one and slapped it in. Cheaper than buying the aftermarket ones and I prefer the size of the stock ones.
 
Reply With Quote
  #6  
Old 11-14-2008
jtfoxman's Avatar
Member
Thread Starter
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Thanks guys and gal! I guess I'm in the market for a new stereo. It lasted me 8-9 years, I don't think that's too bad.

Originally Posted by DisturbedESV View Post
I just had stock radios.... when one hit the dirt I went on ebay and bought another stock one and slapped it in. Cheaper than buying the aftermarket ones and I prefer the size of the stock ones.
I agree, I to like the size of the stock stereo but I have my light switches above the aftermarket stereo now and I really don't feel like moving them.
 
Reply With Quote
  #7  
Old 11-14-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Is it detachable face? If so try cleaning the contacts.
 
Reply With Quote
  #8  
Old 11-14-2008
jtfoxman's Avatar
Member
Thread Starter
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Originally Posted by fddriver02 View Post
Is it detachable face? If so try cleaning the contacts.
Even though I hardly ever take the face off I'll give that a shot.

Thanks
 
Reply With Quote
  #9  
Old 11-14-2008
TheStig88's Avatar
Member
iTrader: (4)
Join Date: Aug 2008
Location: Columbia, Missouri
Posts: 2,120
8-track anyone??
 
Reply With Quote
  #10  
Old 11-14-2008
dakota772's Avatar
Member
Join Date: May 2008
Location: Tucson
Posts: 230
Originally Posted by jtfoxman View Post
Even though I hardly ever take the face off I'll give that a shot.

Thanks
Definitely do that first, at least you may have a little more time before the radio gives up completely. I have a similar problem with my radio and I have looked into replacing the radio face, but that is still $100-$150...so just get a new radio of decent quality and hope for another 8-9 years of playback.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
evilclown312
Suspension Tech
20
05-09-2012 03:17 AM
rickranger93
General Technical & Electrical
4
03-01-2012 08:37 AM
asnider
SOHC - 2.3L & 2.5L Lima Engines
1
04-16-2011 06:14 PM
amgcustoms
Drivetrain Tech
6
08-15-2010 01:04 PM
UnderdogGN
General Ford Ranger Discussion
2
12-07-2007 04:37 PM


Thread Tools
Search this Thread
Quick Reply: Odd CD Player Problem


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.