pics of system post here - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-16-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
pics of system post here

so i can get a good idea of what everyone else has got goin for them and what yours looks like i need to get some better pics of mine and will post them tomorrow. go ahead and lets see what you got?

Name:  SSPX0075.jpg
Views: 1
Size:  13.0 KB

Name:  SSPX0042.jpg
Views: 1
Size:  29.5 KB

Name:  SSPX0166.jpg
Views: 1
Size:  26.2 KB

Name:  SSPX0165.jpg
Views: 1
Size:  23.6 KB
Reply With Quote
  #2  
Old 02-16-2008
S1att3r's Avatar
Member
 
Join Date: Nov 2007
Location: Emory, TX
Posts: 226
mines stock but hopefully about to change.
Reply With Quote
  #3  
Old 02-16-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
only pic i got....lol...12" L7, currently in my subaru, but was in the ranger.

Reply With Quote
  #4  
Old 02-16-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
i have heard alot of good things bout the L7 but i like my *****
Reply With Quote
  #5  
Old 02-17-2008
Member
 
Join Date: Sep 2007
Location: LANSING, MI
Posts: 339
Name:  DSCN09460916.jpg
Views: 0
Size:  147.6 KB 2 elemental designs 9kv.3's D2's powered but a alpine mrp-350. and 99ranger you need to upgrade your power wire too minimum 4 gauge. 8 is too small if you say you have a grand into your stereo and your still not done. **** i have $1000 to go just for my hu and front stage, not to mention more sound deadoning.
Reply With Quote
  #6  
Old 02-17-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
thats acually what i am getting next and i was to go with 0awg
Reply With Quote
  #7  
Old 02-17-2008
Member
 
Join Date: Sep 2007
Location: LANSING, MI
Posts: 339
good choice. only thing i suggest with 0 gauge is dont feed it threw a factory grommet, buy a screw in compression grommet and drill a hole.like this http://cgi.ebay.com/ebaymotors/STING...spagenameZWDVW yes you have to drill a big *** hole but it is worth it.
Reply With Quote
  #8  
Old 02-17-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
that looks like a good idea
Reply With Quote
  #9  
Old 02-17-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
Hey 99ranger4x4offroad!

What kind of subs are those and what size? Specs?




Allen
Reply With Quote
  #10  
Old 02-17-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
power acustik **** 10s 2400w max 1000w rms, dual 2ohm voice coil
270 oz magnet, 89 dB spl
Reply With Quote
  #11  
Old 02-17-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
Thanks! Those are some sick subs dude! I might have to look into those. I used to have the Titanium Phoenix Golds and they shook the ground, now I have the Alpine Type R's. They're ok, but those subs you have probably kill'em...lol


Allen
Reply With Quote
  #12  
Old 02-17-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
well with the subs in my box it weighs prolly 120lbs and i have them down fireing where the port is on the little center hump and it vibrates the cab good
Reply With Quote
  #13  
Old 02-17-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
I was just looking at them on some other websites and e-bay. I've never seen those before but they look wicked man. The power handling is impressive and I read a lot of good reviews about them. It does'nt matter to me what brand they are with power and specs like that they have to pound. Do you like them and how long have you had them?




Allen
Reply With Quote
  #14  
Old 02-17-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
i bought mine off ebay and have had them for 9 months now and they are the best subs i have ever had before i alway ran lightning audio alway around but now i have these i and never going back and i was replaceing the lightning audio subs to often cause i would blow one where it would just stop working altogether or just start a real back cracking sound
Reply With Quote
  #15  
Old 02-17-2008
99ranger4x4's Avatar
RF Veteran
iTrader: (3)
 
Join Date: Jun 2006
Location: Austin, TX
Posts: 12,198
i had one 12" FUBAR Power Acoustik in my truck. 1800watt peak i think, had a 980 watt PA amp...
Reply With Quote
  #16  
Old 02-17-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
so did you like the pa amp cause i have not had one but heard they are not so good
Reply With Quote
  #17  
Old 02-17-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
when i got the ***** i was debating on them or some more lightning audio and here is the lightning audios i was looking at and this place has pretty decent prices because the ***** were 250 when i bought them here they are 160

http://images.google.com/imgres?imgu...n%26safe%3Doff
Reply With Quote
  #18  
Old 02-18-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
I like your style! Kind of like mine, I like the baddest, most intimidating looking sub there is. The looks of those subs just make me feel like they pound. I looooooooooove the huge rubber surround on those. Kind of like my old PG titanium subs but yours are even bigger dude!

Try these bass songs on them: http://www.knocturnalknights.com/roc...te/rfbass2.rar

The password is:rf4lyfe

It is case sensitive. Be careful bro, I don't want you to blow your subs with these tracks......hahahahahahaha!



Allen
Reply With Quote
  #19  
Old 02-18-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
Oh by the way, this is a post your set-up thread so here's mine right now:

[IMG][/IMG]

Sorry about them being so dirty, I just snapped the shot for you right now and did'nt realize they were that bad...lol. They're only 4 or 5 months old.




Allen
Reply With Quote
  #20  
Old 02-18-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
what size amp do you have and do you know where you can get screws for the end caps?
Reply With Quote
  #21  
Old 02-18-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
here is a pic of one of them when i switched them into my new box


[IMG][/IMG]

[IMG][/IMG]
it came with stickers to put on the magnet but i never see that side of the sub so i dont bother me

Last edited by 99ranger4X4OFFROAD; 02-18-2008 at 01:37 AM.
Reply With Quote
  #22  
Old 02-18-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
I have the RF Power Series 551s. I noticed you have RF as well. Here's the info:
http://incolor.inetnebr.com/weisinat.../power551s.htm

I think I have an extra set of screws for these style RF amps. Just let me know where you're at and I'll send them to you. I got them from an RF rep and I think I threw them in my toolbox. I'll take pics of them tomorrow and let you look at them.



Allen
Reply With Quote
  #23  
Old 02-18-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
I also noticed that you have a ported enclosure. How do you like it in your Ranger?

I've always ran a sealed because of the limited space and it's in the cab. I've heard great things from others but what does it sound like ported in the cab? Thanks.



Allen
Reply With Quote
  #24  
Old 02-18-2008
99ranger4X4OFFROAD's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Amarillo, Tx
Posts: 238
ya i got my amp used from a dude i graduated with and it was missing one

cause that is all i need to completely finish my amp situation

Last edited by 99ranger4X4OFFROAD; 02-18-2008 at 02:21 AM.
Reply With Quote
  #25  
Old 02-18-2008
Hardwareman's Avatar
Member
 
Join Date: Feb 2008
Location: Victorville, CA
Posts: 166
All right, hold on. Let me go out to the garage and see if I have them. I'll take some pics and be back in a few.

I'd still like to know how a ported box sounds in the cab though please? Have you had both sealed and ported or just ported? Thanks. Be right back.




Allen
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mounds Meet 3/1/09 Post Your Pics Here! Toreador4x4 Meet & Greet Photos 124 03-05-2009 12:35 AM
post Regular cab system pics borsports Audio & Video Tech 33 04-27-2007 11:22 PM
Post your exhaust system! Wertzy 2.9L & 3.0L V6 Tech 63 01-19-2006 08:50 PM
Anyone here have the "Tremor" system? tbird2340 Audio & Video Tech 16 07-20-2005 10:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:31 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.