Radio = Dead - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-18-2009
hougy's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Cobb, GA
Posts: 206
Radio = Dead

My SONY XPLOD unit has decided it does not want me to listen to the radio anymore. The CD, and AUX work just fine...but when I tune into the radio, I hear nothing. I can hear static and some music if I turn it ALL the way up, and put my head to the speaker. But that just ain't practical, is it?

Some guy said it was the tuner...is this repairable?
Reply With Quote
  #2  
Old 03-23-2009
mps01r6's Avatar
Member
 
Join Date: Sep 2007
Location: dallas
Posts: 84
i would first check to make sure that your antenna did not get disconnected from the back of the radio, and if that is still pluged in then, lets just say that it XPLODED!!! which is typical of most all sony car electronic products. sony's have weak FM/AM tuners in them to begin with. id say its time for a new radio if you want to get one if not then just use the AUX and CD portion untill you can get a new one.
Reply With Quote
  #3  
Old 03-25-2009
FordRangerXLT's Avatar
Member
 
Join Date: Sep 2007
Location: Fitchburg,MA
Posts: 137
The SAME thing happened to my sony xplod head unit. WTF!! I want my radio back. I replaced the antenna because it was bent and that didn't work. I also checked my fuses and those looked fine. Idk
Reply With Quote
  #4  
Old 03-25-2009
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
You need a Pioneer HU my friend.
Reply With Quote
  #5  
Old 03-25-2009
NATEFX407's Avatar
Member
 
Join Date: Dec 2008
Location: Kawartha Lakes, ON
Posts: 459
I always forget that some people actually still listen to AM-FM radio... I don't even have my antenna hooked up. Sirius FTW.
Reply With Quote
  #6  
Old 03-25-2009
crazymikey's Avatar
Member
iTrader: (2)
 
Join Date: Nov 2008
Location: your mom
Posts: 4,008
Your Xplod done gone xploded.
Reply With Quote
  #7  
Old 03-25-2009
FordRangerXLT's Avatar
Member
 
Join Date: Sep 2007
Location: Fitchburg,MA
Posts: 137
sounds like you and I need a new head units hougy
Reply With Quote
  #8  
Old 03-25-2009
DisturbedESV's Avatar
Member
 
Join Date: Apr 2008
Location: Seattle, WA
Posts: 3,115
My stock head unit did that once 'cause the antenna plug came out... check all the wires before you write the whole thing off...

Quote:
Originally Posted by NATEFX407 View Post
I always forget that some people actually still listen to AM-FM radio... I don't even have my antenna hooked up. Sirius FTW.
AUX input FTW... sometimes I wonder why I even bought the 6 in dash... lol
Reply With Quote
  #9  
Old 03-25-2009
crazymikey's Avatar
Member
iTrader: (2)
 
Join Date: Nov 2008
Location: your mom
Posts: 4,008
I have a stock am/fm/single CD unit (does NOT play mp3 cds) if any of you are interested.
Reply With Quote
  #10  
Old 03-26-2009
hougy's Avatar
Member
Thread Starter
 
Join Date: Jul 2005
Location: Cobb, GA
Posts: 206
It's the head unit. I took it out and made sure everything was connected, and I checked the antenna (I even polished the contacts to make sure nothing was interfering with it). Still, no go. Going to see if I can transplant my old head unit radio tuner into the SONY one.
Reply With Quote
  #11  
Old 03-29-2009
FordRangerXLT's Avatar
Member
 
Join Date: Sep 2007
Location: Fitchburg,MA
Posts: 137
Yup mines the head unit also, everything is connected.
Reply With Quote
  #12  
Old 03-29-2009
Sixt9coug's Avatar
Member
iTrader: (7)
 
Join Date: May 2006
Location: Norwalk, CA
Posts: 1,034
As Mikey said up there, I also have a single disc non MP3 CD player sitting around. I also have a 6 disc MP3 player for sale too if you are looking for one, no imput jacks on em though.
Reply With Quote
  #13  
Old 03-29-2009
crazymikey's Avatar
Member
iTrader: (2)
 
Join Date: Nov 2008
Location: your mom
Posts: 4,008
I have a 6 disc as well,but it's fubared.
Reply With Quote
  #14  
Old 04-06-2009
platinum6316's Avatar
Member
 
Join Date: Jan 2009
Location: Scarborough, ON
Posts: 98
Quote:
Originally Posted by hougy View Post
My SONY XPLOD unit has decided it does not want me to listen to the radio anymore. The CD, and AUX work just fine...but when I tune into the radio, I hear nothing. I can hear static and some music if I turn it ALL the way up, and put my head to the speaker. But that just ain't practical, is it?

Some guy said it was the tuner...is this repairable?
Which unit was it?
I have like 3 different Sony Stereo's kicking around here.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Want to Trade: Explorer Radio Bezel for Ranger Radio Bezel - ON platinum6316 Interior, Exterior, Electrical, & Misc. 0 11-26-2011 07:02 AM
radio bezel's rubbery coating has scrached off...how to repaint radio bezel?? jordanvw Interior Semi-Tech 7 05-24-2011 09:37 AM
Ranger XL- trying to replace radio delete with a radio! dch29 Audio & Video Tech 3 03-31-2011 08:11 PM
How-To: Modify your radio bezel to fit a double din radio Redneckstone Interior, Exterior, & Electrical 0 03-31-2010 11:18 PM
Sirius Radio Users. What radio? zabeard Audio & Video Tech 30 06-20-2006 06:00 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.