Stereo turns ON but speakers cut-out in any gear but P or N or Ign in Aux - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-11-2012
Member
Thread Starter
 
Join Date: Jun 2012
Location: New Orleans, LA
Posts: 1
Icon3 Stereo turns ON but speakers cut-out in any gear but P or N or Ign in Aux

Stereo (Radio or CD player) works (turns ON) but speakers cut-out in any gear but Park or Neutral or if Auxiliary selected with ignition key and no volume displayed. Its the stock Pioneer Stero radio/CD6/MP3 player.

What is tied to the radio audio that would cut it out in gear when driving or Auxiliary when parked?! Verified everything else electrical works and all fuses good (even checked on what looked questionable with meter. I suspect something to do with neutral safety switch but can't understand why only radio audio affected?

______________________________________________

A Friend pointed me in the right direction and thought I should share this. The "Clock Spring" is suspect culprit cutting-out the ground to radio speakers and running through Neutral Safety Switch.

I think this is what I have to do to fix my now intermittent stereo audio

*** NOTE battery is disconnected when messing around air bag!
Reply With Quote
  #2  
Old 06-11-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
i cut a pink w/ black stripe wire and my problem went away. also mine only worked with highbeams on.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
eBay / Craigslist Find: Selling my P.I.E. Aux. input converter FRDN-AUX on eBay - Indiana the.hatter Interior, Exterior, Electrical, & Misc. 3 06-27-2012 01:16 PM
eBay / Craigslist Find: Selling my P.I.E. Aux. input converter FRDN-AUX on eBay the.hatter Interior, Exterior, Electrical, & Misc. 1 06-27-2012 10:58 AM
No ign lights, Not cranking, batt ok, but Nothing happening jonouk General Technical & Electrical 10 06-20-2012 01:52 AM
Putting into drive turns speakers off? Jay04Edge General Technical & Electrical 4 09-15-2008 09:20 AM
speakers speakers speakers doug435 Audio & Video Tech 5 01-30-2006 01:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:05 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.