Codes thrown by 2009 Ranger 2.3lt - Ranger-Forums - The Ultimate Ford Ranger Resource


DOHC - 2.3L Duratec / Mazda L Engines Discussions and Topics specific to the Duratec 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-24-2015
Member
Thread Starter
 
Join Date: Jan 2015
Location: Lebanon, IN
Posts: 2
Codes thrown by 2009 Ranger 2.3lt

Does anyone know what's wrong? Last week my truck had a code of P0340 (Camshaft Position Sensor). Running real rough at idle. Smooths out when gas is applied. This week it sent P0300, P0340 and P0400. Still running rough at idle.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
CODES CODES- IDLE issue supraboatguy General Technical & Electrical 1 11-08-2011 02:17 AM
new guy building a 2.3LT from a TC freelife04239 Member Introductions 4 08-16-2010 02:44 AM
Yet another "My mileage sucks" thread, with some other nonsense thrown in. Mrcarcrazy SOHC - 2.3L & 2.5L Lima Engines 23 07-29-2009 04:33 PM
Ranger caught in avalanche and almost thrown off cliff....(5 pix) fx4me General Ford Ranger Discussion 53 02-11-2009 10:22 AM
New shocks, max flex and some mud thrown in too Sonic04Edge Snapshots 16 01-04-2009 11:36 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.