94' 4.0 4x4 a4ld trans problems - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-10-2011
Member
Thread Starter
 
Join Date: Sep 2010
Location: Hamilton, OH
Posts: 4
94' 4.0 4x4 a4ld trans problems

Hey guys this winter has been a pain for my old ranger. I have a HUGE delay going into drive when the truck is cold. I've counted up to 60 seconds before!!!! It still shifts fine and doesnt slip but it does like to downshift early then go right back into the gear it was in..

But i'm guessing this delay is from a bad trans filter or a bad seal? If i let it warm up in park for 3-4 minutes it will only take a few seconds. I checked the fluid and its clean and in the ballpark.

So i'm guessing its slowly dying? Whats the cheapeast way of getting my truck back into commission once she goes out?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: (NJ) A4LD trans Bergz0 Engine & Drivetrain 6 11-24-2014 10:38 AM
a4ld trans help 94rangerx Drivetrain Tech 2 11-14-2011 10:12 AM
how to tell if i have a a4ld trans hitmanmatt Drivetrain Tech 0 10-04-2011 07:27 PM
For Sale: Rebult A4LD auto trans....Al. SHORANGERBIRD Engine & Drivetrain 1 07-26-2010 01:53 PM
A4ld problems.... fearlesscowboy523 Drivetrain Tech 1 01-12-2009 04:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.