High Idle and no accel; New Tranny? - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-18-2007
Branson's Avatar
Member
Thread Starter
 
Join Date: Apr 2005
Location: Princess Anne, MD
Posts: 93
High Idle and no accel; New Tranny?

Hi all,
Saturday I had my first major tranny problems with the truck (~90,000 mi). When starting it up, I noticed that it was idling at 1500 rpm. Then I noticed that acceleration was terrible and that under full throttle, the engine seemed to be shutting out. RPMs dropped immediately and the truck sounded like it was about to shut down. A few hours later I started it up and it was still idling at 1500 rpm. On the way to the shop, the problem of the high idle and acceleration was gone completely. Idling was back down to 7-800 rpm and shifting felt fine. After being at a shop overnight, I just phoned to find out that I need a new transmission. Does this sound like crap to y'all? I mean, to me it seems like it would be more of an electrical type problem or something, and I wouldn't need an entirely new tranny. I think I'm gonna take it to somewhere else for a second opinion. Any clue on what else it could be? I tried searching the forums but couldn't find someone with similar issues.
Reply With Quote
  #2  
Old 09-18-2007
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
+1 on the second opinion.

Before you take it somewhere else, clean your MAF. It's been known to make trannies shift squirrelly.


High idle could also be a vacuum leak or sticking IAC.

The fact that it idled and shifted fine on the way to the shop makes me think there is NOTHING wrong with your transmission.
Reply With Quote
  #3  
Old 09-18-2007
Branson's Avatar
Member
Thread Starter
 
Join Date: Apr 2005
Location: Princess Anne, MD
Posts: 93
I'll try cleaning the MAF. I'll look into the IAC as well. Would Autozone be able to pull those codes? If so, I'm headed there before I drop it off at the next shop. This crap has ruined my day. I figured it can't be the tranny if it's an off and on kind of problem. I mean, tranny problems like that shouldn't be able to fix themselves. And it definitely seemed like there some sort of throttle issue coming into play. Thanks for the advice. I'll let you know how it goes.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
High Idle / Low idle 2003 Ranger 3.0 thom2003 2.9L & 3.0L V6 Tech 1 03-27-2012 01:12 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM
94 2.3 4x4. rough idle, delayed accel. help if u can, please and thanks 94 s-box SOHC - 2.3L & 2.5L Lima Engines 0 01-13-2010 07:11 PM
Screamin Demon Coil VS. Accel impure 4.0L OHV & SOHC V6 Tech 40 10-01-2008 04:31 AM
Accel vs. Screamin Demon 0RangerEdge2 2.9L & 3.0L V6 Tech 3 04-27-2007 12:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.