Installed filter but forgot... - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2007
Member
Thread Starter
 
Join Date: May 2007
Location: Warren, NJ
Posts: 9
Installed filter but forgot...

I just changed my tranny fluid and changed my filter but I just looked in the box and I left the 2 rubber o rings out. Do I have to do it again or am I alright? Thanks
Reply With Quote
  #2  
Old 07-22-2007
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
if there are no O-rings on the filter then pull it back apart IMMEDIATELY and put them on and put it back together. without a good seal to the filter the tranny wont pull fluid up properly and it will starve and not be good.
Reply With Quote
  #3  
Old 07-22-2007
got-dirty's Avatar
Member
 
Join Date: May 2005
Location: Sliding in the skreets
Posts: 3,829
thats a good kick in the nuts
Reply With Quote
  #4  
Old 07-22-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
Quote:
Originally Posted by TireIron
if there are no O-rings on the filter then pull it back apart IMMEDIATELY and put them on and put it back together. without a good seal to the filter the tranny wont pull fluid up properly and it will starve and not be good.
Reply With Quote
  #5  
Old 07-23-2007
06fx4 L2's Avatar
Member
 
Join Date: Mar 2007
Location: SO CAL
Posts: 430
yay extra parts!!!


hate when that happends


JOSH
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I forgot to mention.... Zomby8me Member Introductions 0 12-14-2014 07:02 PM
I completely forgot... 08 Ranger Sport 4x4 General Ford Ranger Discussion 13 06-07-2013 08:48 AM
forgot i had an account here 3.0Rangeron20s Member Introductions 12 03-02-2009 08:08 PM
New exhaust for my Ranger.....Forgot, new member too.. waterboy 2.9L & 3.0L V6 Tech 10 07-21-2007 06:19 PM
Amsoil Ea filter installed ericsmith32 2.3L & 2.5L I4 Tech 16 08-20-2006 03:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.