New slave and clutch+ more tranny noise - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-28-2007
Member
Thread Starter
 
Join Date: Dec 2006
Location: Vermont
Posts: 30
New slave and clutch+ more tranny noise

Just finished the slave and clutch. Very simple, straight forward pain in the *** job. Took like 10 hours. The thing that really ticks me off is that after 65k, my clutch looked brand new, but the slave was covered in fluid.

Anyway, after bleading through about 2 pints with the rear of the truck jacked to the garage ceiling, it is still tough to get into first sometimes. Everything else feels good though. I am having the dealer put on a new thermostat housing seal next week, so I may just have them bleed it again for me.

The real issue is that the "dirty tape player" noise that has always come from the tranny is now much worse. Especially in 5th. Could I have damaged the input shaft bearing wresting the tranny back or, or is possible that the insulation is now gone and that is the difference? Should I worry about it. From what I hear the noise is considered normal.
Reply With Quote
  #2  
Old 12-28-2007
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Yeah, it's recommended that you replace the pilot bearing if you remove the flywheel or have it machined. I didn't replace mine (I didn't reface the flywheel) when I did the old slave replacement........and I have that pilot bearing noise too. Been lucky so far, about 2 years now.
Reply With Quote
  #3  
Old 12-29-2007
Member
Thread Starter
 
Join Date: Dec 2006
Location: Vermont
Posts: 30
so likely the pilot bearing noise is annoying and not necessarily damaging. I would take all that crap off it was going to ruin something. If not I will just live with it until the slave goes again. Which could be sooner than later.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Shifting Issues after Slave and New Clutch Digby17 Drivetrain Tech 8 04-23-2015 02:26 AM
Leaking clutch fluid at slave cylinder and clutch line ttb_addict94 Drivetrain Tech 0 06-05-2014 06:43 PM
'97 Slave Cylinder vs. '03 Slave Cylinder....what is the difference? lifted97ranger Drivetrain Tech 21 01-17-2014 11:38 PM
Cant get slave cyl line out of slave need help Downey Drivetrain Tech 4 09-02-2011 05:44 PM
Ordering new clutch kit and slave cylinder texasbullseye89 Drivetrain Tech 4 03-31-2007 06:00 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.