What could be causing this auto transmission problem? - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-28-2009
Member
Thread Starter
 
Join Date: Aug 2009
Location: IL
Posts: 1
What could be causing this auto transmission problem?

I've been called upon for some transmission advice, but don't know much about diagnosing automatic transmissions...so I call up those who may know.


The vehicle is a '91 Ford Ranger with 130k miles. It was in a 5-10mph fender bender the other day. Cosmetically, the bumper got smushed in, but that's all. I drove the truck to help diagnose what seems to be something else that got knocked loose. From a stop, under normal acceleration, the tachometer works just fine, but the speedometer fluctuates up to about 30mph before it stabilizes. From 0-15mph it does not register any speed. It is hard to tell what gear the truck is in when starting from a stop (1-2 or 2-3). When in that 'mystery' range of 0-30mph, however, the transmission will make a good clunk in between gears.

They also noted the ABS light has come on since the fender bender.

Could the transmission issue be as simple as a loose speed sensor or cable? (i dont know what they have)
Could the ABS be as simple as a loose electrical connection? (once again, not familiar with abs other than it has a gizmo and some wire by the brake )
Reply With Quote
  #2  
Old 08-31-2009
joatmon's Avatar
Member
 
Join Date: Jul 2007
Location: SMC MD
Posts: 54
according to Ford Ranger Speedometers - How They Work the 91's used mechanical speedmoeters, so the problem is either the speedmeter itself, the cable, or the gear that connects it to the tranny.

At the bottom of that link there is a Q&A that fits your speedometer/ABS problem really well, except it doesn't apply to a 91.

TO bind up the speedometer cable and also mess with the ABS, must have hit something hard at 5-10 mph
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rebuilt Auto Transmissions (Transmission Authority or Transmission Depot? Stevenc General Ford Ranger Discussion 3 12-22-2015 08:31 PM
Auto computer causing issues? Matthodge1992 General Technical & Electrical 1 11-15-2013 06:48 PM
Could bad hubs be causing a horrible catching/grinding on 99 4x4 sneakysnead General Ford Ranger Discussion 0 07-16-2013 08:27 PM
is the efan causing my truck to have a problem? lifted97ranger General Ford Ranger Discussion 5 07-23-2006 07:12 PM
So what could be causing this CEL Code.. its a good one.. rngprerunner General Technical & Electrical 4 06-07-2006 05:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.