Passenger side HID not working - Ranger-Forums - The Ultimate Ford Ranger Resource


Exterior Semi-Tech General discussion of exterior for the Ford Ranger.
Sponsored by:
Sponsored by:

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-06-2009
lownslow95's Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: Worton, MD
Posts: 176
Passenger side HID not working

I have had this issue for about a week or so now, and its getting to the point where I don't know what else to do/look at. My passenger HID flickers on and off for like 5 seconds, then shuts off completly. I checked all the connections, they seem fine. I checked the fuse, thats fine. All the wiring seems fine. I don't know where else to look. Anyone have a clue?
Reply With Quote
  #2  
Old 06-06-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
You need a relay kit
Reply With Quote
  #3  
Old 06-06-2009
Jp7's Avatar
Jp7 Jp7 is offline
Member
iTrader: (9)
 
Join Date: Sep 2007
Location: My LED lab or on the dyno
Posts: 2,970
might need new bulb or ballast, they don't last forever. Changed both fogs once already. Had mine about 2 years, w/o relay kit.
Reply With Quote
  #4  
Old 06-06-2009
lownslow95's Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: Worton, MD
Posts: 176
How much is a bulb/ballast. I really only need one, but if they aren't sold seperatly, ill end up getting two.
Reply With Quote
  #5  
Old 06-06-2009
trucks423's Avatar
Member
iTrader: (2)
 
Join Date: Jul 2008
Posts: 687
the passenger ballast on my truck went out in about a week with out the relay kit.
Reply With Quote
  #6  
Old 06-06-2009
08XLT4x4's Avatar
Member
iTrader: (7)
 
Join Date: Mar 2008
Location: bomba shack
Posts: 3,257
Quote:
Originally Posted by lownslow95 View Post
How much is a bulb/ballast. I really only need one, but if they aren't sold seperatly, ill end up getting two.
2 seconds on google and youll find 100's of places that sell them... or ebay works too
Reply With Quote
  #7  
Old 06-06-2009
lownslow95's Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: Worton, MD
Posts: 176
I try to stay away from ebay as much as possible, but thanks.
Reply With Quote
  #8  
Old 06-06-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Make your own relay kit. Can be done very cheaply(under $10)
Reply With Quote
  #9  
Old 06-06-2009
Smakes's Avatar
Member
iTrader: (5)
 
Join Date: Nov 2008
Location: nowhere
Posts: 235
really shane?
Reply With Quote
  #10  
Old 06-06-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
OP....figureout what isn't working right. Take your good working side bulb and plug it inot the non working side ballst, then take the bad working side bulb and put it on the good working side ballsat. that'll tell you if it's the bulb or the ballast thats wrong.

But...Always...run a relay kit. It takes power from your battery instead of the stock plug. it uses the stock plug as a switch to turn the relay on. Less strain on your stock harness, and it's just smarter. Plus, it only uses ONE factory plug, it ties both left and right hids to eachother, so no issues of left/right out of timing.




Smakes: $4 relay, $2 worth of wires, less than $3 of connectors.
Reply With Quote
  #11  
Old 06-06-2009
Smakes's Avatar
Member
iTrader: (5)
 
Join Date: Nov 2008
Location: nowhere
Posts: 235
hrm.. im gonna look into this relay you speak of.. currently if i turn my hids on before my engine my passenger side will flicker and go out, solution is to turn the headlight switch off then back on
Reply With Quote
  #12  
Old 06-06-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Relay kit cures that issue.
Reply With Quote
  #13  
Old 06-07-2009
TrePaul86's Avatar
Member
iTrader: (8)
 
Join Date: Apr 2007
Location: Gresham, OR
Posts: 1,369
Relay kit.

eBay is the best place for replacement bulbs and ballasts. Cheap and faily good quality. Had my kits for over 2 years now.
Reply With Quote
  #14  
Old 06-07-2009
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
I'm not seeing how a relay kit is going to fix anything. This sounds like a bad bulb or ballast, nothing to do with power feeding it.
Reply With Quote
  #15  
Old 06-07-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
The relay kit won't fix it but it will prevent it from happeneing again. Not having a relay kit caused the ballast to go bad, shane posted above about it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HID Not Working Larryhazan02 General Technical & Electrical 6 02-28-2014 05:34 PM
Want to Buy: 60/40 Passenger Seat OR 60/40 Set (Driver & Passenger) - VA frontroyalva Interior, Exterior, Electrical, & Misc. 0 04-11-2011 11:24 PM
HID lights on working on one side BmillerEdge General Technical & Electrical 12 03-04-2011 11:57 PM
HID's not working. karrbass4life General Technical & Electrical 29 04-17-2009 06:52 PM
Front drivers side wheel/tire sit's in farther than the passenger side? mobileaudio219 General Ford Ranger Discussion 9 10-12-2008 09:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.