1999 4x4 Problem!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-06-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Albertville, AL
Posts: 4
Icon5 1999 4x4 Problem!!

i have a 1999 ford ranger 4x4, and I'm having problems with my 4 wheel drive. when i put it in 4 when drive, it locks in at the transfer case, but the front wheels don't lock in. any advice?
Reply With Quote
  #2  
Old 07-06-2010
morris's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
i wanna say it's a vacum problem. either there is a vacum leak and they are not engaging the hub or the hubs are bad. please wait for others to chim in. i think it's a vacum problem but i forget what year they went to live axel in the front.

if it turns out to be the hubs, man up and get the manual locking ones from warn or whoever else makes them.
Reply With Quote
  #3  
Old 07-06-2010
Member
Thread Starter
 
Join Date: Jul 2010
Location: Albertville, AL
Posts: 4
thats what i wanna do anyways!
Reply With Quote
  #4  
Old 07-06-2010
jtfoxman's Avatar
Member
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Go with the manual like morris says. You will never have an issue with them. Just a pain sometimes to lock them in instead of on the fly like the vacuum ones. Much more reliable then the crappy vacuum one's from Ford, less expensive too.
Reply With Quote
  #5  
Old 07-06-2010
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
I thought you can only get manual hubs on the 98 and older 4x4's?
Reply With Quote
  #6  
Old 07-06-2010
0RangerEdge2's Avatar
Member
iTrader: (2)
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,593
It's what I run. Never had a problem with them. Granted I used 98 4x4 parts to convert my truck to 4x4, that's why I have these as I couldn't use the vacuum system.

Save yourself the headache of PVH and just get the Rugged Ridge ones.

15001.70 - AVM - NOW SHIPPING - Ford Ranger Manual Locking Hubs PAIR - AVM Manual Locking Hub PAIR For 1997-00 Ford Rangers : Tellico 4x4

EDIT: The description says 97-00, that is incorrect. It's actually 98- early 2000.

EDIT 2: Cheaper price

http://www.jeepsandstuff.com/15001-70.html

Reputable seller

http://www.summitracing.com/parts/RGG-1500170/

Last edited by 0RangerEdge2; 07-06-2010 at 11:58 PM.
Reply With Quote
  #7  
Old 07-07-2010
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
I had the same problem on my 99, There is vacuum lines running in to the back of the hub, check them for cracks or switch to manual hubs.
Reply With Quote
  #8  
Old 07-07-2010
morris's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
Quote:
Originally Posted by 01RangerEdge View Post
I thought you can only get manual hubs on the 98 and older 4x4's?
this was why i said for the OP to wait. i wasn't sure if it was 98 or 99. i knew others would know fo sho but i put him in the right direction.
Reply With Quote
  #9  
Old 07-07-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
also check the acutator that locks the front hubs sometimes they go bad...i think its mounted on the front diff
Reply With Quote
  #10  
Old 07-07-2010
cchsbuzz19's Avatar
Member
iTrader: (5)
 
Join Date: Jul 2007
Location: North Canton, Ohio
Posts: 2,417
Yep its most likely the Vacuum hubs not locking in. Its a common problem during the 98-00 years. Get the AVM hubs from Rugged Ridge very reliable, I've got them on mine. You can switch it to 4wd on the fly you just have to make sure the hubs are locked in.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1999 Ford Ranger XL AC Problem davidlwoolard General Ford Ranger Discussion 2 08-02-2015 05:54 PM
Buying 1999 XLT Supercab 4.0 Auto 4x4 - tranny clunk bradvr4 Drivetrain Tech 6 04-27-2015 06:27 PM
1999 brake problem jessy james General Technical & Electrical 0 02-05-2013 09:02 PM
1999 Ford 1999 Ranger Sport - $1,000 SeanL Ranger Based Vehicles 0 01-07-2012 05:29 PM
4 hi problem on 1999 4.0 shane4.0 General Technical & Electrical 0 12-10-2010 10:49 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:00 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.