anyone elses JD traction bars make a lot of noise? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-25-2010
Tys 4x4 FTW's Avatar
RF Veteran
Thread Starter
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
anyone elses JD traction bars make a lot of noise?

so i made sure everything was tightened down last night on the traction bars, really havent paid any attention to them since i got them on. but im hoping i only overtightened. because now when the axle flexes one way or another, just barely, it sends a creaking vibration noise through the whole truck.

too lazy to go loosen them back up right now just hoping thats hte problem.
Reply With Quote
  #2  
Old 04-25-2010
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
No noises, no nothing here regarding the JD Bars. Mine did make alot of noise when I overtightened and literally split the front bushings in half. The bar would grind against the front bracket and squeek and rattle.



I'd check your cab mount bolts. Trevor had one back out on him....it was making a thud sound and you can feel it just driving on the street.
Reply With Quote
  #3  
Old 04-25-2010
Tys 4x4 FTW's Avatar
RF Veteran
Thread Starter
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
thing is, it didnt do this yesterday before i tightened the bars lol

i literally parked it, tightened them went in and went to bed. drove to work this morning and it made the sound
Reply With Quote
  #4  
Old 04-25-2010
ccernst's Avatar
Member
 
Join Date: May 2009
Location: Kansas City, MO
Posts: 380
I just put mine on in Feb...no noises. I forget how it it all went together on the front attachment.
Reply With Quote
  #5  
Old 04-25-2010
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
I'm stumped, Ty. I really don't think it's the bars making the noise. I'm more leaning towards something else is wrong, coincedently started after you messed with the bars.
Reply With Quote
  #6  
Old 04-26-2010
winks's Avatar
Member
iTrader: (5)
 
Join Date: May 2005
Location: Jackson, New Jersey
Posts: 4,872
I've had mine for a long time Ty, and they've never made a noise on me. Keep an eye on the mounts, maybe there's something wrong there.
Reply With Quote
  #7  
Old 04-26-2010
ccernst's Avatar
Member
 
Join Date: May 2009
Location: Kansas City, MO
Posts: 380
Maybe one of the bars has some tension on it when the others does not?
Reply With Quote
  #8  
Old 04-26-2010
Scrambler82's Avatar
Old Guy User… ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,769
Quote:
Originally Posted by ccernst View Post
Maybe one of the bars has some tension on it when the others does not?
My thought exactly… chk the preload on the bars (distance between mount to mount).
Chk the Bar Bushings as FX4w… stated too.
Bolt tightness use a Torque Wrench ALWAYS, loosen and double check if necessary.

Noise when using metal parts usually means metal to metal contact somewhere.

Thinking here… (smoke) check the Spring Bushings also; if you preloaded the bars too much and the Spring Bushings were on the weak side they may have broken down, maybe not but check just in case.

luck,
Reply With Quote
  #9  
Old 04-26-2010
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Remember....bushings aren't supposed to be "superman" tight...I did that and royally EFFED my stuff up. Just enough to "bubble" the bushing and make the two washers touch the center brass bushing.
Reply With Quote
  #10  
Old 04-28-2010
Tys 4x4 FTW's Avatar
RF Veteran
Thread Starter
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
loosened things up and sprayed some silicone spray in there. everything is peachy now :)
Reply With Quote
  #11  
Old 04-28-2010
Scrambler82's Avatar
Old Guy User… ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,769
great !
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
does anybody elses truck rattle when lugging t5cents General Technical & Electrical 25 01-31-2010 08:58 PM
anyone elses engine tick? Biz 4.0L OHV & SOHC V6 Tech 19 01-22-2008 11:46 PM
anyone elses efan suck? dodge_cowboy Drivetrain Tech 58 08-13-2006 01:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:25 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.