Cold Natured 2010 4.0 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-10-2011
Dbl Deuce 5's Avatar
Member
Thread Starter
 
Join Date: Aug 2010
Location: Aurora,IN
Posts: 20
Icon5 Cold Natured 2010 4.0

I have a 2010 Sport with the 4.0 has about 9,000 miles and runs pretty good. My question is if anybody else has trouble with theirs being a little cold natured. Starts up fine, but runs kinda rough for first 2-3 mins. It does this even if it is 90 degrees out. Just curious if anyone else has noticed this problem, and if there is a solution or is it something I will have to live with? Thanks 225. P.S. It has done this ever since it was new.
Reply With Quote
  #2  
Old 10-10-2011
frosty's Avatar
Member
iTrader: (1)
 
Join Date: May 2010
Location: Ontario
Posts: 244
Why not just ask the dealer to take a look at it? Being that new means you still have tons of warranty left.
Reply With Quote
  #3  
Old 10-10-2011
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
You definetly have an issue
Reply With Quote
  #4  
Old 10-10-2011
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
Join Date: Mar 2009
Location: Clinton, Ontario
Posts: 8,181
That's definitely not right... the only time mine acts up is when starting after just driving it a very short distance.
Reply With Quote
  #5  
Old 10-10-2011
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Only time mine runs rough after start is when its below -20 or so. It will smooth out after about a 15 seconds of chugging.
Reply With Quote
  #6  
Old 10-10-2011
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Quote:
Originally Posted by FULLSCALE View Post
That's definitely not right... the only time mine acts up is when starting after just driving it a very short distance.
That's funny. I know a lot of Fords that do that. Run to the gas station, shut it off and it won't start or runs rough.
Reply With Quote
  #7  
Old 10-11-2011
Dbl Deuce 5's Avatar
Member
Thread Starter
 
Join Date: Aug 2010
Location: Aurora,IN
Posts: 20
Quote:
Originally Posted by frosty View Post
Why not just ask the dealer to take a look at it? Being that new means you still have tons of warranty left.
Yeah that's probably what I'll end up doing, it's just kinda inconvenient. My dealer is a good 45 mins. away. Plus It's not going to do it when it is hot so they will probably want me to leave it overnight. If I can squeeze a loaner out of them it wouldn't be so bad, otherwise giant PIB. I was just curious if any one else had this issue. It's really more of an annoyance than anything, it just irritates me. You buy a brand new vehicle you want it to be perfect you know? Especially after spending so much money on it. Oh well. Thats how it goes sometimes I guess
Reply With Quote
  #8  
Old 10-12-2011
Member
iTrader: (2)
 
Join Date: Mar 2010
Location: C
Posts: 661
no man thats not how it goes, it is one hell of an investment and i would expect it to be perfect. take it to the dealer this is what the warranty is for. i had the short drive restart thing a few times but ever since i turn the key over and wait for the gas light to go out it fires right up. never had a problem since. just pretend its a diesel and wait then crank.
Reply With Quote
  #9  
Old 10-12-2011
morris's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
Use your phone or camera to take a vid to show them.
Reply With Quote
  #10  
Old 10-12-2011
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
I have a 2010 4.0 and mine does not do that
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New Truck Videos: Mojave Road 2010 and SCORE LDC 2010 PreRun rngprerunner Vehicle & Meet Videos 6 05-04-2010 09:08 AM
Green Cold Cathodes - Installed FORZDA New Ideas 7 04-07-2005 04:19 PM
idea for a 04 3.0L cold air intake 04edge 2.9L & 3.0L V6 Tech 5 03-18-2005 10:07 AM
On Startup When It's Cold eXtremePC General Technical & Electrical 15 12-30-2004 03:57 AM
Hard start after cold. Ranger1 General Ford Ranger Discussion 3 12-29-2004 04:14 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.