Electrical Short, how to find it...HELP... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-26-2010
Bs03fx4's Avatar
Member
Thread Starter
 
Join Date: Jun 2010
Location: Omaha, El Paso
Posts: 121
Electrical Short, how to find it...HELP...

Baught this truck a little over 2 years ago, and the day i baught it, the dealership put a brand new battery in it. A month ago, i woke up for work and the battery was dead. I let it sit all day, and the next day it started up fine, ran good for 3 weeks, and the other day it was dead again. Ended up buying a new battery. Now it starts stronger then ever, but the battery light is on. I took it to autozone and had them test the battery and alternator. Both Stong, but the guy did a test where he removed the positive and touched the neg to a ground, then would touch the pos to the post and it would have a tiny spark. He said that means i have a short somewhere which is causing the battery light to come on???

thoughts???

Also about 6 months ago i did a LED gauge swap, and after that is when i noticed the light. I thought it was just cause the LEDS are so bright?

Thoughts??
Reply With Quote
  #2  
Old 07-26-2010
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
You will have that little spark when you reconnect, you're powering up the PCM and things like the radio memory. What do you have for volts with the truck off and key off at the battery posts.
Reply With Quote
  #3  
Old 07-26-2010
Bs03fx4's Avatar
Member
Thread Starter
 
Join Date: Jun 2010
Location: Omaha, El Paso
Posts: 121
Quote:
Originally Posted by rolsmojave3 View Post
You will have that little spark when you reconnect, you're powering up the PCM and things like the radio memory. What do you have for volts with the truck off and key off at the battery posts.
He didn't say what they were with the truck off. He just said in general had 14 volts.
Reply With Quote
  #4  
Old 07-26-2010
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
That would be with it running.
Reply With Quote
  #5  
Old 07-26-2010
Bs03fx4's Avatar
Member
Thread Starter
 
Join Date: Jun 2010
Location: Omaha, El Paso
Posts: 121
Idk then. He just told me that battery n alternator r good. Hmmm
Reply With Quote
  #6  
Old 07-26-2010
Bs03fx4's Avatar
Member
Thread Starter
 
Join Date: Jun 2010
Location: Omaha, El Paso
Posts: 121
could it be something as simple as a LED in my gauges not plugged in all the way or something?? Because if i remember correctly, the light came on after the LED swap? im going to take it apart today and see what i come up with, otherwise i have no idea. Only other wiring ive meesed with is audio, and ive dont plenty of audio to know how to do it right..

any main things i should check? before i take it to a shop???
Reply With Quote
  #7  
Old 07-26-2010
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
If it happened after you messed with the instrument panel, I would guess you messed up.
Reply With Quote
  #8  
Old 07-26-2010
Bs03fx4's Avatar
Member
Thread Starter
 
Join Date: Jun 2010
Location: Omaha, El Paso
Posts: 121
Well, i fixed it. I started to think, and a month ago when i took the truck in to get the intake manifold gaskets replaced, i told the guy i wasnet popping a CEL. He told me he did the test and it was popping a CEL, but the light was burnt out or not working. I started to think about that today so i tore apart the guages and checked all the bulbs. then i switched the theft bulb with the CEL bulb, put it all back together, and started the truck.........................NO BATTERY LIGHT ANYMORE!!!

thing is the battery i just replaced 2 days ago was only 2 years old. i wonder if it was even bad. I didnt even have them check it because when i was taking it out of the truck, i dropped it and it was leaking acid, so i just bought a new one. yet its hard to believe the battery went bad after only 2 years. O well, after installing this new battery, it starts strong and instantly!!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger short box vs S-10 Short box (Dimensions) 20102wdRanger General Ford Ranger Discussion 8 01-19-2013 10:32 AM
Power Door lock short help mtnstyne General Technical & Electrical 0 10-15-2011 04:09 PM
Please help me find an impossible-to-find part!!! nswelton General Ford Ranger Discussion 10 11-28-2010 03:12 PM
Ranger has a 2" Body Lift, e-brake cable is now short! Help! IndianScout 1" & 3" Body Lifts 2 10-03-2010 11:04 AM
'84 Ranger Wipers - Short Circuit gordonb1 General Technical & Electrical 2 11-14-2007 10:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:11 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.