engine idle - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-07-2011
Member
Thread Starter
 
Join Date: Mar 2011
Location: springfield, ohio
Posts: 1
engine idle

had low engine idle (500-600) running rough. The codes say fuel banks to lean. So I replaced the MAF sensor, now engine idles at 1400. Tried cleaning the throttle body but no results. Any ideas what my problem is? This is a 2001 ranger 4x4

Last edited by shotgunr40; 03-07-2011 at 08:21 PM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 rough idle/slow return to idle whiskeybreath SOHC - 2.3L & 2.5L Lima Engines 1 11-27-2014 05:06 PM
low idle when slowing down to idle j_huhnke General Ford Ranger Discussion 13 04-06-2012 05:58 AM
High Idle / Low idle 2003 Ranger 3.0 thom2003 2.9L & 3.0L V6 Tech 1 03-27-2012 01:12 AM
low idle when slowing down to idle j_huhnke 4.0L OHV & SOHC V6 Tech 2 03-25-2012 10:26 AM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.