engine overheating update... now running too cold? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-21-2008
Member
Thread Starter
 
Join Date: May 2007
Location: Cordova, TN
Posts: 183
engine overheating update... now running too cold?

in my last post i talked about my ranger overheating. I replaced both the thermostat and the fan clutch, and now the damnest thing... it won't heat up enough! Its almost like the new thermostat is stuck open already. It takes a LONG time to heat up enough to make the heater blow hot, and as soon as you turn the heat on, the temp gauge goes down to almost the bottom.

Do you think the new thermostat is bad? Or is there anything else that could possibly cause this? I tested the old thermostat in a pot of boiling water and it opened up just fine, so I'm sure that wasn't the original problem.
Reply With Quote
  #2  
Old 05-21-2008
SparkYZ's Avatar
Member
 
Join Date: Nov 2007
Location: Granada Hills, CA
Posts: 679
Is the new thermostat the right temperature?
Reply With Quote
  #3  
Old 05-22-2008
Member
Thread Starter
 
Join Date: May 2007
Location: Cordova, TN
Posts: 183
yes, 192*. I'm starting to wonder if it was labeled wrong
Reply With Quote
  #4  
Old 05-22-2008
Bankrupt's Avatar
Member
 
Join Date: May 2008
Location: Tuscaloosa, Alabama
Posts: 20
sounds like the thermostat is stuck open. Id get a new one. The last one i bought came with a warranty so that if it stuck within a short period of time i could return it for free. Try replacing it and let us know what happens.
Reply With Quote
  #5  
Old 05-22-2008
Member
Thread Starter
 
Join Date: May 2007
Location: Cordova, TN
Posts: 183
yeah the new one I put in it is the "Failsafe" kind from autozone. I may just take it back and get one from ford.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
help!! engine running too rich panzer 2.9L & 3.0L V6 Tech 25 09-13-2013 11:36 AM
3.0 v6 ford excape engine cold running issue myersth 2.9L & 3.0L V6 Tech 0 10-11-2012 04:40 PM
Possible running TOO COLD ????? Flames SOHC - 2.3L & 2.5L Lima Engines 9 09-13-2011 08:14 PM
heater core froze over winter now i have overheating issues 93rangerXLT4x4 4.0L OHV & SOHC V6 Tech 9 03-26-2010 09:19 PM
Overheating in 4x4 only? and cold heat? Bigdank 4.0L OHV & SOHC V6 Tech 24 12-08-2007 03:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.