Evaporator problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-03-2013
powerstroketech's Avatar
Member
Thread Starter
 
Join Date: Jun 2010
Location: Mississauga, Ontario
Posts: 7
Evaporator problem

I did a three inch body lift on my 2010 Ranger. There is a step in the instructions where you have to adjust the a/c line to clear a belt pulley. Soon after, my evaporator leaked out, i could smell PAG oil inside. I had my evaporator replaced last week, i picked it up friday. Monday morning i smell PAG oil again, and the compressor is short cycling. Has anyone else had this problem after installing a three inch body lift?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 06:58 AM
a/c evaporator housing j99ranger4x4 General Technical & Electrical 21 07-25-2010 07:08 AM
removing the evaporator box PetesPonies SOHC - 2.3L & 2.5L Lima Engines 1 05-04-2008 06:32 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.