A few newbie questions - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-19-2007
Phil93Xlt's Avatar
Member
Thread Starter
 
Join Date: Nov 2007
Location: West Allis, WI
Posts: 2
A few newbie questions

I recently bought a 93 Xlt, first pickup i've owned....moved from the UK last year...and theres a few things that ive noticed that i'd like some help with.

A squeeqing noise from the front end when the engine has warmed up and it is not under load. any ideas??

some rather large person must have owned the truck before me, because the truck sort of leans towards the drivers side. Would changing the shocks solve this??

the temp gauge moves up and down from middle of the guage to about 3/4 is this normal...its still within the normal limits?? But no car ive owned before has ever done that.

Hopefully someone can help

Thanks
Phil
Reply With Quote
  #2  
Old 11-19-2007
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
squeek=Probably the belt or a pully up front, try belt dressing/lubing the tensioner pully.
lean=Ranger lean, Check the rear leaf spring shackles to see if they're broke, if not, ignore the lean.

Temp gage=Check coolant or get a coolant flush.
Reply With Quote
  #3  
Old 11-19-2007
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
rangers have what we call a "ranger lean". Gas tank and driver on same side....itll lean. I'm sorry, petrol tank. lol.
Reply With Quote
  #4  
Old 11-19-2007
ChrisR1S's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2007
Location: Kenbridge, VA
Posts: 263
yeah the lean is probably normal and the squeeking is prob a belt or mayb a pully...tensioner or ideler?
Reply With Quote
  #5  
Old 11-20-2007
Phil93Xlt's Avatar
Member
Thread Starter
 
Join Date: Nov 2007
Location: West Allis, WI
Posts: 2
thanks for the replies

Quote:
Originally Posted by rolsmojave3
squeek=Probably the belt or a pully up front, try belt dressing/lubing the tensioner pully.
may sound stupid but what would i use to lube the tensioner pully?
Reply With Quote
  #6  
Old 11-20-2007
cdn2x4ranger's Avatar
Member
 
Join Date: Oct 2007
Location: thief river falls,mn
Posts: 57
you could use wd-40. or some other type of penetrating fluid. thats what i used.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Hello, I'm a newbie here whit a few questions. brentmc 4.0L OHV & SOHC V6 Tech 11 02-27-2014 11:42 AM
A few general questions from a newbie dadof2 General Ford Ranger Discussion 7 09-03-2010 10:10 AM
Newbie here...with a few questions 68ranger General Ford Ranger Discussion 3 01-13-2010 05:22 PM
A FEW QUICK QUESTIONS? FROM A NEWBIE BILTRITE BULLIES General Ford Ranger Discussion 18 07-16-2009 02:14 PM
hi newbie have few problems miran587 Drivetrain Tech 11 07-12-2009 05:19 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:03 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.