Hell and back - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-20-2006
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2004
Location: Belleville, Il
Posts: 972
Hell and back

Well this weekend has been a weekend from hell and then a resurection for the banana. To start things off this weekend was Mud Bash. Which was a blast as far the event but not for the truck. Welll the day start out at 5 in the morning which was bad enough, and then from there a hour drive to get there. Well I meet up with Matt(RangerBoy02FX4) and we were going to just tear it up with the rangers. Well my ranger started out going great and i went threw the pit with no problem. Well I got out and got Matt and was like you going in or you just here to watch. Well we both went in and so I got gutsy(sp) thinking if i get stuck matt will pull me out well i went threw everything no problem. Well i decided that i was going to go threww some deep stuff or atleast try it well matt went the other way and he didnt come out where i was. So i backed up and went around to go and find him and he was stuck well i will let him tell you guys about that, but all i have to say is Matt made rangers look tough. well anyways now for the bad news well on the way to help matt i hit some water to quick and sucked water in the intake well i thought that it would dry out and be ok well by the time matt got out well i was wrong and it was full of water. So matt pulled me out i took the air box off drained the water out and pulled the filter out of the tube. So i let it set the rest of the day and called my uncle to come and trailer it home. well all i can say it was zach (zabeard) alll over again. Well i got it home went to work and the next day started to tear the topend apart to clean all the water out and clear all the cylinders. So after letting it soak over night and cleaning all the cylinders with brake parts cleaner and tanny fluid in the cylinders to keep them lubed. well after that was done we put it all back together and tried starting it well it wouldnt start so we figured it was flooded with gas since we were cranking it with no plugs in or no intake on. So we let it sit then after about five minutes it finally started and she ran for a second. Welll the goosebumps set in and the adrline start to race threw me. well i looked at the tail pipe and well my truck took a ****. so after that we put the air box back in and started it one last time well it heistated for a bit then started and ran like a champ. so sorry for the long post but alot has happened to the truck and me in the last two weeks that i kind of have to gloat cause i am kind of proud of myself for fixing it. So on with the pictures




the airbox after it



the intake manifold and all the water



the truck as it waited for the tow


and the tow truck



the beginning of the tear down




and the rest of the tear down

i will have pics of the truck running and have videos up when i get another chance to get pics of the truck
Reply With Quote
  #2  
Old 06-20-2006
Member
 
Join Date: Oct 2005
Location: Anoka, MN
Posts: 33


holy **** man....
Reply With Quote
  #3  
Old 06-20-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
paragraphs please! I'll see pics when im home
Reply With Quote
  #4  
Old 06-20-2006
Trigger01's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 18,788
Congrats on getting it fixed yourself, but it really sucks that it got messed up and it sucks even more that you had to get towed home by a Dodge(I think Zach did too).
Reply With Quote
  #5  
Old 06-20-2006
rangererv's Avatar
Member
 
Join Date: Mar 2005
Location: Dearborn Michigan
Posts: 4,376
^^ ya zach was towed by a dodge.

dang man, that must have sucked.
Reply With Quote
  #6  
Old 06-20-2006
gatorblue92's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Delaware
Posts: 8,238
man i really like your truck... and im glad you got it fixed okay
Reply With Quote
  #7  
Old 06-21-2006
Member
 
Join Date: Mar 2005
Location: St. Louis, MO
Posts: 208
im still rollin around with mud ALL over my truck....my skidplate is being held on with 3 bolts....ill clean it tomorrow.

i wish i could post some video, i filmed about 60% of the day, but when i got home, i realized my camcorder wasnt working...im not sure if it will be salvaged or not, but ill let you know

i also wish i would have done a few more runs, but its scary when my truck is one of the only ones still with a car payment, and its my daily driver....ill post pics tomorrow if i remember
Reply With Quote
  #8  
Old 06-21-2006
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2004
Location: Belleville, Il
Posts: 972
well thanks guys its been a lot of work and i am not out of the clear just yet... i am thinking about draining all the fluids like oil radiator and possibly tranny fluid too but the first two for sure.... is there anything else i should do while trying to resurert it
Reply With Quote
  #9  
Old 06-21-2006
Needforspeed3685's Avatar
Member
 
Join Date: Aug 2005
Location: Lowell, AR
Posts: 1,836
Quote:
Originally Posted by BananaEdge
.... is there anything else i should do while trying to resurert it
CLEAN THE ENGINE!
Holy crap how'd you get so much mud below the intake manifold? Did you submerge the engine???
Reply With Quote
  #10  
Old 06-21-2006
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
dang that is alot of water.

hope it gets all cleaned up. you better flush all the fluids.

i feel your pain.
Reply With Quote
  #11  
Old 06-21-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Wow....well done!
Reply With Quote
  #12  
Old 06-21-2006
Member
 
Join Date: Dec 2005
Location: Ft Hood, TX
Posts: 1,779
that sucks man but at least your truck looks bad ****. lol.
Reply With Quote
  #13  
Old 06-21-2006
KARPE's Avatar
Member
 
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
don't start every sentence with "well" please hurts my brain to read your giant paragraph
Reply With Quote
  #14  
Old 06-22-2006
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2004
Location: Belleville, Il
Posts: 972
ok well i got the truck out and got it to move under its own power
that should be a video of the truck
Reply With Quote
  #15  
Old 06-22-2006
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
dang man, water water everywhere..

good luck on the fixes
Reply With Quote
  #16  
Old 06-25-2006
01_WhiteRanger's Avatar
Member
 
Join Date: Jun 2006
Location: Quincy, WA
Posts: 37
That reminds me of when a crappy old quad died on me when I was out in deep water except the water went in through the exhaust and it would start. Alot of steam from the exhaust though
Reply With Quote
  #17  
Old 10-19-2006
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2004
Location: Belleville, Il
Posts: 972
man its been a while since i been on i geuss since this thread was made but to update it. i got it up and running as in the video but now the motor has no compression on the driver side....... so i have no clue on what to do next... so any help would be great or some kind of insight!!!!!!!!!!!! i am planning on takeing the intake manifold off again and cleaning all that up again and then i plan on pulling the driver side valve cover off but i really have no clue what to look for once i get it off????? so if anyone knows anything about timeing or timing chains or any reason y i dont have it let me know
Reply With Quote
  #18  
Old 10-19-2006
5speedin2.3's Avatar
Member
 
Join Date: May 2005
Location: Livonia, Mi
Posts: 12
get a compression tester. could be valves hanging open who knows.
i have a 4.0 if you need one.
Reply With Quote
  #19  
Old 10-19-2006
BRENSRANGER's Avatar
Member
 
Join Date: Jul 2006
Location: Minnesota
Posts: 1,308
crazy stuff,glad its running again
Reply With Quote
  #20  
Old 10-19-2006
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2004
Location: Belleville, Il
Posts: 972
its not though
Reply With Quote
  #21  
Old 10-19-2006
BRENSRANGER's Avatar
Member
 
Join Date: Jul 2006
Location: Minnesota
Posts: 1,308
sorry man,i should of said hope you get it running soon,my mistake.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Blown U-Joints and a hell of alot of mud! (facebook content haha) 56K NONO immortal_vision Snapshots 14 04-07-2011 01:04 AM
Wire hell - Power Mirror ojaneri Interior Semi-Tech 2 06-04-2005 10:44 AM
From 10 days of hell..to a day in heaven aftermarket General Ford Ranger Discussion 6 04-10-2005 11:53 PM
Night from hell.....Truck dead *long story* FLPanther General Ford Ranger Discussion 12 03-14-2005 06:41 PM
what the hell? optikal illushun Ranger-Forums Office 6 10-23-2004 07:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:35 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.